VLAN help, routing?

35 pts.
Tags:
Layer 3 switches
PowerConnect
Routing
VLAN
I have some Powerconnect 6248 Layer 3 switches that I'm working with. I've never worked with VLANs before so I'm totally lost here. I don't know CLI so I'm using the GUI. I have workstations and servers set up on 192.168.0.x/255.255.255.0, workstations on 192.168.1.x/255.255.255.0, and workstations on 192.168.2.x/255.255.255.0 Switch1 is going to be 192.168.0.x Switch2 is going to be 192.168.1.x Switch3 is going to be 192.168.2.x Switch4 is going to be 192.168.2.x I have VLAN10 set up on S1 and VLAN20 set up on S2, and VLAN30 will be on S3 and S4. How do I get machines in VLAN10 to communicate with machines in VLAN20, VLAN30. (ping, file share, etc) I set port 1 to trunk but that doesn't seem to be working. I'm hoping someone familiar with these switches can help.

Software/Hardware used:
powerconnet 6248
ASKED: November 9, 2009  7:36 PM
UPDATED: November 10, 2009  9:50 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hi,

For these vlan to communicate, you got to have at least one trunk in which these vlans will flow and communicate. Most of the time, this trunk is connected to the gateway(router or any layer3 device).You have to create subinterfaces on the router or any layer3 device for this vlans to flow on the trunk you created. Its like building a huge tunnel<trunk> and inside this tunnel are small tunnels<subinterfaces> wherein the vlans will communicate. So even if they are in different subnet, they have something in common, and that is the trunk that this vlans flow.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Solareclipse2
    Wow. Ok, that makes sense. Can you tell me how to do that?
    35 pointsBadges:
    report
  • Solareclipse2
    Right. These are layer 3 switches so they should be doing the routing. What I have right now is port 1 set as a trunk on switch 1 and switch 2. That is to say port 1 on each switch is a member of VLAN10 and VLAN20, etc. even though s1 doesn't have any other ports assigned to VLAN20 and vice versa. Switch1 (vlan10) has a pc with the following configuration 192.168.0.35 255.255.255.0 192.168.0.230 Switch2 (vlan20) has the following pc configuration 192.168.1.30 255.255.255.0 192.168.1.230 Right now the PCs cannot communicate with each other. If I assign the one pc the same gateway as the other PC they can communicate. So something is wrong there and I don't know what it is.
    35 pointsBadges:
    report
  • Solareclipse2
    Here's my config, if it matters.
    !Current Configuration:
    !System Description "PowerConnect 6248, 2.2.0.3, VxWorks5.5.1"
    !System Software Version 2.2.0.3
    !
    configure
    vlan database
    vlan  10,20
    vlan association subnet 192.168.0.0 255.255.255.0 10
    vlan association subnet 192.168.1.0 255.255.255.0 20
    exit
    stack
    member 1 2
    exit
    ip address 192.168.59.230 255.255.255.0
    ip routing
    interface vlan 10
    name "VLAN10"
    routing
    ip address  192.168.0.230  255.255.255.0
    ip netdirbcast
    ip irdp
    ip irdp address 255.255.255.255
    no ip proxy-arp
    ip mtu 1492
    exit
    interface vlan 20
    name "VLAN20"
    routing
    ip address  192.168.1.230  255.255.255.0
    ip netdirbcast
    ip irdp
    ip irdp address 255.255.255.255
    no ip proxy-arp
    ip mtu 1492
    exit
    username "administrator" password ec1776b4be44c51109a86021cc8d6c50 level 15 encr
    ypted
    !
    interface ethernet 1/g1
    switchport mode trunk
    switchport trunk allowed vlan add 10,20
    switchport trunk allowed vlan remove 1
    exit
    
    !
    interface ethernet 1/g11
    switchport access vlan 10
    exit
    exit
    35 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following