VLan Cisco 2950

555 pts.
Tags:
Cisco 2950
VLAN
I am in need of some serious help. Please see the URL where i put in my question and scenario http://www.4shared.com/file/127413877/2f6e1b34/cisco2950.html
ASKED: August 24, 2009  7:24 PM
UPDATED: August 24, 2009  8:33 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

Firstly, one of the configs you have posted is for a switch

<b>interface FastEthernet0/23
switchport access vlan 10
switchport mode trunk
spanning-tree portfast</b>

You should NEVER put portfast on a link to another switch, this command turns off spanning-tree, and you don’t want to do that on a connection to another network device, that is a sure fire way to get loops in the network.

Also you don’t want the <b>switchport access vlan10</b> command on there. Leave the deafult VLAN to be VLAN1. On the ports where you have the devices in that VLAN then use the <b>switchport access vlan x</b> command to put that interface into the vlan.

The other device is not a switch, but a router. If it IS a switch then this is totally the wrong config, but I am fairly sure from that config, that this is a router. you can confirm this by using the <b>show version</b> command. It will tell you the hardware and software versions.

On the router you have the following

<b>interface FastEthernet0/0.10
description VLAN 10 DeviceManagment
encapsulation dot1Q 10
ip address 192.168.100.1 255.255.255.0
ip policy route-map PowerPath
!
interface FastEthernet0/0.9
description EMAR Vlan 35.x
encapsulation dot1Q 9
ip address 192.168.35.1 255.255.255.0
ip policy route-map PowerPath</b>

First remove the policy commands, because these are probably effecting the routing (you can put them back later if needed).

The interface FastEthernet0/0.9, if you want it to be the router for VLAN 35 should have the command <b>encapsulation dot1Q 35</b> as the number specifies the VLAN ID in the encapsulation (it is convention to number the sub-interface with the same number, so you may want to remove <b>interface FastEthernet0/0.9</b> and create <b>interface FastEthernet0/0.35</b> for this).

So you need to do the following commands in config mode

<b>interface FastEthernet0/0.10
no ip policy route-map PowerPath
!
no interface FastEthernet0/0.9
!
interface FastEthernet0/0.35
description EMAR Vlan 35.x
encapsulation dot1Q 35
ip address 192.168.35.1 255.255.255.0
end</b>

Now you have created the vlans on the router correctly, you also need to create them on the switch, as there is no VTP with a router, these are not created automatically.

On the switch do the following commands in config mode

<b>vlan 10
name DeviceManagment
sta active
!
vlan 35
name EMAR
sta active
!
interface FastEthernet0/23
no switchport access vlan 10
no spanning-tree portfast
!
end</b>

On interfaces you want in VLAN 10 do the command

[Bswitchport access vlan 10</b>

and on interfaces you want in VLAN 35 do the command

[Bswitchport access vlan 35</b>

Then you should find it all works correctly.

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Kwt712
    Here is my problem. I am trying to do a VLAN up in the Attic on 24 port switch with port 1 and 2 to be as .31 and port 3 thru 24 would be .35 (Cisco 2950). What is confusing that the Switch Room where the connection is coming up in the attic doesn’t show VLAN setup for .35. Basically it is acting as a dummy switch to my knowledge. I don’t see any configuration on the Attic switch by plugging the console cable in the back of the switch. Is there a way to pull up the configuration on the attic switch. If there is none, how can I configure that switch or load configuration on it to make it work with VLAN. http://www.4shared.com/file/127413877/2f6e1b34/cisco2950.html The link has a picture and some configuration that i put together. Thanks
    555 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following