V4R4 upgrade to V5R4 or V6R1 WDS

120 pts.
Tags:
iSeries
iSeries V6R1
V4R4
V5R4
I need some more expert input on this issue. I am currently on a S30(V4R4). Yes i know its old, but it has lasted 12 years. I now have the option to go to a preloaded  520(running with V5R4 or V6R1 OS & lic pgms). My V4R4 box has the STRPDM cmd where I can compile the following types of pgms...RPGLE, CLLE,BND, CRTSRVPGM, CRTRPGMOD, CRTBNDCL, CRTBNDRPG, etc. Here are all the lic pgm on my S30(V4R4). View 1 Licensed Installed Program Status Description 5769SS1 *COMPATIBLE OS/400 - Library QGPL 5769SS1 *COMPATIBLE OS/400 - Library QUSRSYS 5769SS1 *COMPATIBLE Operating System/400 5769SS1 *COMPATIBLE OS/400 - Extended Base Support 5769SS1 *COMPATIBLE OS/400 - Online Information 5769SS1 *COMPATIBLE OS/400 - Extended Base Directory Support 5769SS1 *COMPATIBLE OS/400 - System/38 Environment 5769SS1 *COMPATIBLE OS/400 - Example Tools Library 5769SS1 *COMPATIBLE OS/400 - AFP Compatibility Fonts 5769SS1 *COMPATIBLE OS/400 - *PRV CL Compiler Support 5769SS1 *COMPATIBLE OS/400 - Host Servers 5769SS1 *COMPATIBLE OS/400 - System Openness Includes 5769SS1 *COMPATIBLE OS/400 - GDDM 5769SS1 *COMPATIBLE OS/400 - Common Programming APIs Toolkit 5769SS1 *COMPATIBLE OS/400 - Ultimedia System Facilities 5769SS1 *COMPATIBLE OS/400 - PSF/400 Fax Support 5769SS1 *COMPATIBLE OS/400 - Extended NLS Support 5769SS1 *COMPATIBLE OS/400 - ObjectConnect 5769SS1 *COMPATIBLE OS/400 - AS/400 Integration for NT 5769SS1 *COMPATIBLE OS/400 - QShell Interpreter 5769SS1 *COMPATIBLE OS/400 - Domain Name System 5769SS1 *COMPATIBLE OS/400 - Directory Services 5769SS1 *COMPATIBLE OS/400 - Digital Certificate Manager 5769AC3 *INSTALLED Crypto Access Provider 128-bit for AS/400 5769AS1 *COMPATIBLE WebSphere Application Server for AS/400 5716CL1 *INSTALLED ADTS CS/400 5716CL1 *INSTALLED CODE/400 5716CL1 *INSTALLED VRPG CLIENT/2 5763CL2 *INSTALLED Application Dev ToolSet Client Server/400 5763CL2 *INSTALLED CoOperative Dev Environment/400 for Windows 5763CL2 *INSTALLED VisualAge for RPG for Windows 5769DG1 *COMPATIBLE IBM HTTP Server for AS/400 5769FW1 *INSTALLED IBM Firewall for AS/400 5769JC1 *COMPATIBLE AS/400 Toolbox for Java 5769JV1 *COMPATIBLE AS/400 Developer Kit for Java 5769JV1 *COMPATIBLE Java Developer Kit 1.1.7 5769PT1 *COMPATIBLE Performance Tools for AS/400 5769PT1 *COMPATIBLE Performance Tools - Manager Feature 5769PW1 *COMPATIBLE App Dev ToolSet for AS/400 - SEU 5769PW1 *COMPATIBLE App Dev ToolSet for AS/400 - Others 5769PW1 *COMPATIBLE App Dev ToolSet for AS/400 - App Dev anager 5769PW1 *COMPATIBLE App Dev ToolSet for AS/400 - AppDict Services 5769QU1 *COMPATIBLE Query for AS/400 5769RG1 *COMPATIBLE ILE RPG for AS/400 5769RG1 *COMPATIBLE S/38 compatible RPG III for AS/400 5769RG1 *COMPATIBLE RPG for AS/400 5769RG1 *COMPATIBLE *PRV ILE RPG for AS/400 5798RZG *INSTALLED AS/400 Service Director 5769SA2 *INSTALLED IBM Integration Services for FSIOP 5769ST1 *COMPATIBLE DB2 Query Mgr and SQL DevKit for AS/400 5769TC1 *COMPATIBLE TCP/IP Connectivity Utilities for AS/400 5763XD1 *INSTALLED Client Access/400 Optimized for Windows 5769XE1 *COMPATIBLE Client Access/400 Express for Windows 5769XW1 *INSTALLED Client Access/400 Windows Family Base ========================================================================= View 2 Licensed Product Program Option Description 5769SS1 OS/400 - Library QGPL 5769SS1 OS/400 - Library QUSRSYS 5769SS1 *BASE Operating System/400 5769SS1 1 OS/400 - Extended Base Support 5769SS1 2 OS/400 - Online Information 5769SS1 3 OS/400 - Extended Base Directory Support 5769SS1 6 OS/400 - System/38 Environment 5769SS1 7 OS/400 - Example Tools Library 5769SS1 8 OS/400 - AFP Compatibility Fonts 5769SS1 9 OS/400 - *PRV CL Compiler Support 5769SS1 12 OS/400 - Host Servers 5769SS1 13 OS/400 - System Openness Includes 5769SS1 14 OS/400 - GDDM 5769SS1 15 OS/400 - Common Programming APIs Toolkit 5769SS1 16 OS/400 - Ultimedia System Facilities 5769SS1 17 OS/400 - PSF/400 Fax Support 5769SS1 21 OS/400 - Extended NLS Support 5769SS1 22 OS/400 - ObjectConnect 5769SS1 29 OS/400 - AS/400 Integration for NT 5769SS1 30 OS/400 - QShell Interpreter 5769SS1 31 OS/400 - Domain Name System 5769SS1 32 OS/400 - Directory Services 5769SS1 34 OS/400 - Digital Certificate Manager 5769AC3 *BASE Crypto Access Provider 128-bit for AS/400 5769AS1 *BASE WebSphere Application Server for AS/400 5716CL1 *BASE ADTS CS/400 5716CL1 1 CODE/400 5716CL1 2 VRPG CLIENT/2 5763CL2 *BASE Application Dev ToolSet Client Server/400 5763CL2 1 CoOperative Dev Environment/400 for Windows 5763CL2 2 VisualAge for RPG for Windows 5769DG1 *BASE IBM HTTP Server for AS/400 5769FW1 *BASE IBM Firewall for AS/400 5769JC1 *BASE AS/400 Toolbox for Java 5769JV1 *BASE AS/400 Developer Kit for Java 5769JV1 2 Java Developer Kit 1.1.7 5769PT1 *BASE Performance Tools for AS/400 5769PT1 1 Performance Tools - Manager Feature 5769PW1 *BASE App Dev ToolSet for AS/400 - SEU 5769PW1 1 App Dev ToolSet for AS/400 - Others 5769PW1 2 App Dev ToolSet for AS/400 - App Dev Manager 5769PW1 3 App Dev ToolSet for AS/400 - AppDict Services 5769QU1 *BASE Query for AS/400 5769RG1 *BASE ILE RPG for AS/400 5769RG1 2 S/38 compatible RPG III for AS/400 5769RG1 5 RPG for AS/400 5769RG1 6 *PRV ILE RPG for AS/400 5798RZG *BASE AS/400 Service Director 5769SA2 *BASE IBM Integration Services for FSIOP 5769ST1 *BASE DB2 Query Mgr and SQL DevKit for AS/400 5769TC1 *BASE TCP/IP Connectivity Utilities for AS/400 5763XD1 *BASE Client Access/400 Optimized for Windows 5769XE1 *BASE Client Access/400 Express for Windows 5769XW1 *BASE Client Access/400 Windows Family Base We no longer use the HTTP server, firewall, NT integration or java feature. Will I need the entire WDS suite or just certain options inorder to replicate my V4R4 lic pgms What are the translated lic pgms names on on V5r4 or V6R1? thxs



Software/Hardware used:
520

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Discuss This Question: 5  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • TomLiotta
    There is a potentially important difference between V5R4 and 6.1 for the compilers. At V5R4, all compilers are included in the single cost of the 5722-WDS product. That product includes the Application Development Toolset -- PDM, SEU, etc. Various components are in different options that may be separately installed, but they are all available for you on the install media if you have the product. At 6.1, there 5761-WDS has four separate components -- one base and three separately orderable features. The three features break out as (1) ILE compilers, (2) "Heritage" (OPM) compilers, and (3) Application Development Toolset. Essentially everything you mentioned for "types of pgms" would be under (1) and (3). I include (3) there only because you also mentioned STRPDM. You are very fortunate to have investment in ILE modules and programs for so long. It's very likely that you will have little or no problem with ignoring the optional OPM compilers. But you might have some difficulty getting used to the replacement(s) for PDM, SEU and everything else under (3) Application Development Toolset. You can certainly order that feature at 6.1; it is just separate and has a separate cost. (Whether your total cost will be higher or lower than it was 12 years ago isn't known. It's quite possible that you'll be fine.) Regardless, the replacement toolset used to be WDSC. And that is more or less replaced by a new toolset at 6.1 --the Rational Developer stuff. (I haven't had to deal with that for my personal systems; so I don't have a good grasp of details there. It's handled by another group in the office environment.) For an official breakdown, see IBM WebSphere Development Studio for System i V6R1. For some less technical discussion, see IBM Rational Software Delivery Platform for System i . And for some commiseration, see What is the current application that replaces the old WDS. Overall, if you can go to i 6.1, it's probably worth it in the long run. If you want the two-step through V5R4, the initial confusion will be much less. Note that V5R4 is probably getting close to an end-of-life announcement though. Need more discussion? Tom
    125,585 pointsBadges:
    report
  • Svocal
    Tom Once again... thank you for expert knowledge on the subject. It has been most helpful. Just to clarify a bit more. You mention at V6R1 5761-WDS has 4 components., one base, (1) ILE, (2) OPM compilers & (3) App Dev Toolset. What comes in the Base component? What are (2) OPM compilers? You say my strpdm & seu are the (3) APP DEV TOOLSET. You say that is replaced by RDI... are you refering to just the App dev toolset or the entire 5761-WDS (4 features)? If I go to V6R1, can I just stay & use 5761-wds or do i have to use RDI? or did I misunderstand something. My other question is. Lets i migrate all my data and code to V6R1 box. Do I need WDS installed on the box for our pgms(software) to run? I know I wont be able to make mod or compile, but will our collection software run? This is my situation. We have the option to acquire a "previously owned" 520 (V6R1). Lets say it doesnt have the WDS or Query/dev tool kit. It is P30 tier. I can now only imagine the costs will be high to purchase the WDS & query products just for our one programmer shop to make mods. We are less than 100 employees. My thought was this. Have our V4R4 box migrated to the 520(V6R1) production box. Buy a p05 tier v6r1 box for development, load the essential wds /query/sql dev tool set on it. Make pgm mods on it and then copy/restore the compile objects to the production p30 box. Does that sound feasible? Stephen.
    120 pointsBadges:
    report
  • 65GTO
    I would migrate from the S30 to a 520 running V5R4 that also has WDS program products. I would forget acquiring the 520 V6R1 machine that does'nt have WDS. Last month I migrated a old S30 to a 520 running V5R4 and then to a 520 running V6R1 and had no issues.
    335 pointsBadges:
    report
  • TomLiotta
    Does that sound feasible? Yes. IMO, that's your best direction to go -- as long as your P30 system keeps IBM support. Since that will be your main database system, it is much more in need of fundamental support. If you have a P05 box that has your development environment, everything can be done through it. There is a possibility that the only licensed product you'll need installed on your P30 will be the OS. There will be some procedural changes and potentially some changes on any client PCs, especially if you have PC applications that make use of Client Access APIs -- but those would necessarily undergo a major change anyway with the jump all the way up to 6.1. If terminal emulation is the major use of Client Access, you're possibly better off just using an emulator such as MochaSoft's or one of the open source ones. The entire System i Access product isn't needed just for terminal emulation. And iSeries Navigator access is a no-cost option, so most management functions might never need terminal access. Tom
    125,585 pointsBadges:
    report
  • Svocal
    Tom Once again, thank you. If i just have the OS running on the 520 6.1 box, will i not need the Client access product feature installed? On V5R4 it is(5722XE1 - Iseries Access for Windows, 5722XW1 - Iseries Access Family). What is the difference between the two? The way the users connect to our current As400(v4R4) is thru the green screen(client access cd installed on all our pc's) and we use its data transfer(to/from the AS400) feature. In 5.1-4 it is called IBM Iseries access for windows. Also If some my CL pgms run queries, then I assume I will need the 5722qu1 & 5722ST feature installed on the P30 box for the queries to run? Stephen
    120 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following