Twinax AS/400 printer failure

35 pts.
Tags:
AS/400
AS/400 printing
Hi, I have a fault with my AS400. Current setup includes 4 twinax consoles connected to 4 twinax printers. I’m having a problem with PRT02. It suddenly stopped printing. The device status shows ‘Powered off or not available’. I tried to ‘Start’ the device under the Work with Printers menu but I get a message waiting with error code CPA3387 – 'device is not powered on or varied on or in use by another job'. Under Display device description, the printer settings match all other existing printers on the system EXCEPT the ‘Allocated to’ section which shows   Job Name: QSYSARB User: QSYS Instead of Job Name: PRT01 (or PRT03 or PRT04) User: QSPLJOB I’ve deleted the device PRT02 in an attempt for the system to auto-config but this failed so I manually configured the device to its original setting. Please note that I did not restart the machine after deleting the device. Is this needed in order for the machine to Auto-config the printer? Right now I don’t understand why the printer stopped working and why I can’t start the device again. Any advice will be appreciated.

Software/Hardware used:
AS400

Answer Wiki

Thanks. We'll let you know when a new response is added.

WRKWTR – END
WRKWTR – START
VARY OFF THEN VARY ON

——————————————————————————————————————–

Might be better to restart the writer <i>after</i> the device has been varied off then varied on.

Discuss This Question: 11  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Koohiisan
    You don't need to restart the AS400 in order for it to detect and configure devices. You will need auto-configure enabled, though. Have you tried killing the printer job if it is still active in wrkactjob? Have you varied it on (off, then on)? Have you tested the twinax cable to verify it is still working and receiving signal at that location (in case another connection prior to this station has been damaged/disconnected)? Those are my initial steps.
    5,020 pointsBadges:
    report
  • NickHutcheson1
    Twinaxe. Cool. What changed? Device description, cableing, more devices on the same controller / line with the same address as the PRT02? If the writer job is still active, ENDWTR. Double check the description you created for the correct controller/line/address. Do these steps in order. Power off the writer. Wait 10 seconds. VRYCFG PRT02 *off. Display the status to make sure it is varied off. Power on the writer. Wait 10 seconds. VRYCFG PRT02 *on. Strprtwtr PRT02. Answer any formtype messages or alignment messages.
    1,380 pointsBadges:
    report
  • TomLiotta
    Job Name: QSYSARB If the device is allocated to QSYSARB, there is no writer active. I get a message waiting with error code CPA3387... And you can't start a writer because the writer fails from CPA3387. How many twinax ports do you have available? If you run PRTDEVADR for the twinax controller, does that device show up in the right location? Tom
    125,585 pointsBadges:
    report
  • Efie
    Koohiisan I tried making the printer unavailable and then available (I suppose this is what you mean by “vary on” and “vary off”. I haven’t seen “vary on” or “vary off” for printer, only for displays. The twinax cable signals the console which powers the display. I don’t have a conflicting printer (or workstation) all others are working properly. These are: Display Printer Comment DSP01 none Master display DSP02 PRT01 Working DSP03 PRT02 Problem Printer DSP04 PRT03 Working DSP05 PRT04 Working CADSP06 CAPRT05 Working, using window CADSP07 CAPRT07 Working, using window NickHutchesor Nothing has ever changed on our hardware configuration I checked the address and there are no conflictions at all, see table below: Switch Setting> 0 1 2 3 Port 0 DSP01 *DSP 3486 BA Port 1 DSP02 PRT01 DSP03 PRT02 *DSP *PRT *DSP *PRT 3487 HC 5256 2 3487 HC 4214 2 Port 2 DSP04 PRT03 DSP05 PRT04 *DSP *PRT *DSP *PRT 3487 HC 4214 2 3407 HC 4214 2 Port 3 Port 4 I ended the writer Powered off the writer with the 10 seconds wait VRYCFG PRT02 *off. Display the status to make sure it is varied off. Powered on the writer with the 10 seconds wait VRYCFG PRT02 *on. Strprtwtr PRT02. Infact I deleted the entire printer set up/description and reconnected the printer hoping for auto-config to do the “set-up” (I verified the auto-config to be set to 1), and this still didn’t work. Any messages: same on I keep getting: writer PRT02 cannot use device PRT02 because the device is not powered on, varied on or in use by another job TomLiotta The twinax cable signals the console which powers the display. I don’t have a conflicting printer (or workstation) all others are working properly. These are: Display Printer Comment DSP01 none Master display DSP02 PRT01 Working DSP03 PRT02 Problem Printer DSP04 PRT03 Working DSP05 PRT04 Working CADSP06 CAPRT05 Working, using window CADSP07 CAPRT07 Working, using window I tried using the command you gave me but it generates a lot of print jobs on our printrer. I also discovered the command WRKSPLF Opt5 for QPDCDEVA Switch Setting> 0 1 2 3 Port 0 DSP01 *DSP 3486 BA Port 1 DSP02 PRT01 DSP03 PRT02 *DSP *PRT *DSP *PRT 3487 HC 5256 2 3487 HC 4214 2 Port 2 DSP04 PRT03 DSP05 PRT04 *DSP *PRT *DSP *PRT 3487 HC 4214 2 3407 HC 4214 2 Port 3 Port 4 I hope this helps, I tried all these things. Thanks for your time
    35 pointsBadges:
    report
  • TomLiotta
    I tried using the command you gave me but it generates a lot of print jobs on our printrer. I'm not sure what that means. The PRTDEVADR command doesn't generate any jobs at all; it just prints a short report that shows the relationship between device descriptions and ports/switches for a single device controller. I also discovered the command WRKSPLF Opt5 for QPDCDEVA Yes, QPDCDEVA is the report generated by the PRTDEVADR command. Your output shows that the system expects device PRT02 to be on port 1 with switch address 3. You need to ensure that the printer is indeed set for switch address 3 (and that it is cabled into port 1). By the looks of it, you have this printer connected to port 1 because it's attached with DSP03 and DSP03 is working correctly, right? DSP03 is a 3487 HC terminal. It is used to configure the attached printer switch setting. Do you have a manual for your 3487 terminals? Do you know how to access the switch settings for these devices? Tom
    125,585 pointsBadges:
    report
  • Bigmac46
    Getting in this late but if writer restart gets "IN USE" - TRY this . CALL PGM(QSPENDWA) PARM(&PRINTER - IBM's way to end what I affectionally call a "RUN AWAY PRINTER" . Have used it a couple of time when no matter what I tried I coild not get a printer back on line because of "IN USE" message even if varied off. May take a few minutes to run.
    1,000 pointsBadges:
    report
  • Splat
    You may have done this already, but I'd recommend you check the cabling. It's been a bit since I've dealt with twinax, but a poorly seated connector can cause issues.
    7,565 pointsBadges:
    report
  • Efie
    [...] Twinax AS/400 printer failure [...]
    0 pointsBadges:
    report
  • Efie
    Hi Guys, i tried a couple other things over and above what you all have suggested. i gone as far as testing the cables a second time and even replacing the IBM console with a new one. I get the same test results as before: PRT02 does not work, I jhave redirected the displays printouts to another displays printer such that the two displays (DSP03 and DSP04) are sharing a printer. This i did through STRDFU. The message I get when printing is: PRT02 is either powered off, unavailable for use or in use by another job. The printer is still under Job name: Qsysarb and user qsys (which is not the case with other jobs) Given what I have gone through so far Im thinking its a software related matter thus I am going full on with further playing around with your suggestion, addative to which I am researching on this "QSYSARB" as it does not seem to stop inspite of the commands you have provided to assist me in. i have never seen this before (well I am not he most experienced in these) but I am open and keen to learning it. If you have further ideas, or addatives on previous discussions, they are more than welcome. Many thanks to all of you for your time and efforts. Efie
    35 pointsBadges:
    report
  • djac
    Is the printer connected to the terminal's parallel port? If so, could someone have been playing with the terminal set-up and 'turned off' the printer capability?
    900 pointsBadges:
    report
  • Efie
    [...] Twinax AS/400 printer failure [...]
    0 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following