AS/400 Tag Directory

Featured AS/400 Questions

  • Error in calling RPGLE program from CL

    I have a job running under subsystem. This job is using a CL program which inturn calling RPGLE program. The CL program is failing in call statement to RPGLE with following error message in jobog: Pointer not set for location referenced. Pointer not set for location referenced. Pointer not set for...

    Mayurp5 pointsBadges:
  • Error code CWBCO1048

    I keep getting a CWBCO1048 A firewall or blockage or Time-out occurred trying to connect IBM i. How do I cure this. It seems to happen in only this one branch and not in any others? Thanks Leo

    superbru43115 pointsBadges:
  • Modify hexa string value in CL

    I have a hexa string and I want to modify some value while running program through CL below is the hexa string. X'011F011F000000000F099999999FC9020160309FF0D5 404040F9F9F9E3000000000F40404040404040') In the above string I have a date 20160309. Now I want to change this date to current date.

    97834441841,465 pointsBadges:
  • Why is CL the native language of AS/400?

    Why is CL (Control Language) the calling native language of AS/400? And why it is a driver program?

    Angelg5 pointsBadges:
  • New line in message formatting in CL program

    I want to insert a new line in message formatting in CL program. Like Name new line and details new line and rem details. How can insert a new line in message formatting?

    sivakesava285 pointsBadges:
  • How to pass numeric data to CL program from AS/400 command line

    Hi All, I want to pass numeric data of length (8 0) to my CL program while calling from AS/400 command line but program is not receiving correct value into the program. Can anyone please help me how to pass numeric data?

    Mohan K695 pointsBadges:
  • CPD0304 when using SUBR and ENDSUBR in CLLE

    I know I've run into this the past, but I can't remember the fix.  I am using V5R4 and trying to use CALLSUBR in my CLLE.  I end my mainline with a RETURN, then I have a SUBR/ENDSUBR... and a 2nd SUBR/ENDSUBR.. then a ENDPGM.  When the compiler hits the 2nd SUBR I get a CPD0304 and it rejects...

    JamesR90 pointsBadges:
  • Use of variable CPYTOIMPF command

    How do I use a variable as the target file in CPYTOIMPF in a CL program?

    tonycs10 pointsBadges:
  • IIF function

    I have 2 tables: First table: 1- name 2- position 3- nationality 4- visa No. Second table: 1- Position 2- No of visas. 3- No of used visas. 4- No of remaining visas. But I want to use IIF function when add new position in first table increases the no of used visas in the second table automatically....

    khalid1155 pointsBadges:
  • CL/400 – How to convert Spool file to Notepad

    Hello Friends, I have a question. In my current project, I have to covert a spool file to notepad and this notepad I have to send it as an attachment to one email address. Question 1: How can I convert spool file to notepad? Question 2: How can I send a notepad as attachment to one email address?...

    BibinGeorge130 pointsBadges:
  • Suppress CPI8072 message when using SNDNETSPLF

    We have an interactive CL program that uses SNDNETSPLF to send a spool file to a second outq on the same AS400 running V5R4. After the operation has completed the user receives the message and has to press Enter before the job will continue. Is there a way to suppress this message without...

    Oldtonew135 pointsBadges:
  • iSeries Access session won’t connect or even give a status, just remains blank

    We're running V6R1 on our iSeries (AS/400, IBM System i) and using IBM i Access 7.1 (Client Access, iSeries Access) with it. All of our PCs are on Windows 7. Every user has a .ws file that they use for starting sessions with their preferences, and it opens via PCSWS.exe. Today, one user cannot...

    ukcazo5315 pointsBadges:
  • Increase size of output file in CL used in DSPJRN command

    I am trying to increase the size of the output file in a CL used in the DSPJRN command. I need to set the OUTFILFMT to *TYPE5. My OUTFILE is being created in QTEMP  - so OUTPUT(*outfile) OUTFILE(QTEMP/DCSTAUDWK1) How can I do this? DSPJRN JRN(&JOURNAL) FILE((DCSCIM) (DCSTCIMU) + (DCSCIU)...

    fischurder5 pointsBadges:
  • Using two same files from different libraries in a RPGLE program.

    Hi All, Please guide me for the following problem. I got stuck into it. I want to operate same file from two different libraries in a RPGLE program. Remember we are taking the file names at runtime. So we don?t know the structure of files. Like the record format name etc. Again somehow I retrieve...

    navinnegi45 pointsBadges:
  • CPYSPLF from one profile to another

    Is there a command thru which we can copy the spool file from one profile to other?

    PRIYAS40 pointsBadges:
  • Read selective file in CL by using OVRDBF

    How do I read selective file in CL by using OVRDBF by positioning to from particular record till selective record? Lets say I have Emp (record format is REC) file which is having 10 records (rrn or key field). Now I want to read file from 2nd record till 8th  record, how can we do this with...

    hndajad195 pointsBadges:
  • Client Access AS/400 ESC key to go to work with all spool files

    How can I change the Client Access AS/400 ESC key to go directly to the "Work with All Spool Files" screen?

    SharonAHB5 pointsBadges:
  • Passing variables from CL to QMQRY

    Hi, I have a CL that get parameter and run QMQRY. When I run it, I get a prompt: "Type a value for variable "x" and press enter". Why I get it even though I pass the parameter? The CL: " PGM PARAM(&X) DCL VAR(&X) TYPE(*CHAR) LEN(8) STRQMQR QMQR(LIB1/QRY1) OUTPUT(*OUTFILE)...

    felixb95 pointsBadges:
  • How to delete specific spool files

    I am not that familiar with command line code as access has been restricted and converted to screen options so forgive me. The task is every month I need to delete specific spool files > 9 months old with specific form type. Originally my thoughts were to: Create formatted file to copy the five...

    Stage15 pointsBadges:
  • EPSON LQ 590 CPI issue

    Hello, I have specified 20 CPI in my CL program using override command, but the printer still prints only 15 CPI. I'm printing information on a pre-printed form hence have positioning issues due to font size. Please advise.

    umesh135 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following