We have a new Data Collector (Model: Symbol,MC3000)that works with Win CE 5.0 but we have Win CE 4.2 , and we can't upgrade our Win CE 4.2 to 5.0, what shall we do?