Does anyone know if WAS 5.1 will work using the JDK 1.5 version?