startup program not autostarting when called in QCTL

45 pts.
Tags:
AS/400 programming
QCTL
V5R4
I have a fully re-written startup program placed in my library,and for some reason if i pwrdwn/IPL or after option21 backup startup program does not autostart but if i call the program it works,the system value is set to look at mystartpgm in mylib but doesn't work instead gives message saying "Program specified will not be run" and leaves box in restricted state.



Software/Hardware used:
AS400 V5r4

Answer Wiki

Thanks. We'll let you know when a new response is added.

The start up program is just an autostart job in QCTL. Look at the sbs description and find the jobd which should be qstrupjd. Then look at that jobd and check the user. The user needs to have enough authority to access and run the start up program you have created and to start any services, subsystems or jobs that you are autostarting. Usually your operators group profile works well. If that doesn’t work display your jobd (in text) and copy paste it to this board and I may be able to tell you what is wrong.

_________________________

The QSTRUP program is generally run under the QPGMR user profile.
WRKJOB QSTRUPJD will display the userid running the program then view the joblog.
The error listed will explain why your startup program is failing.
You can change the jobd as suggested or CHGPGM to USRPRF *OWNER.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • TomLiotta
    Note that CHGPGM USRPRF(*OWNER) won't make any difference if the program is never run. The error text shown was "Program specified will not be run". But what message ID is it? And where was the message found? Tom
    125,585 pointsBadges:
    report
  • TomLiotta
    “Program specified will not be run.” That's the 1st-level text of CPI0915, but it's not clear where the message may appear. Probably the QHST queue, probably the joblog of an auto-start entry in the controlling subsystem (and probably sent from within program QWDAJPGM in job QSTRUPJD) and probably in QSYSOPR. As said above, the QSTRUPJD joblog is the best place to look for the reason your program wasn't run. Most common is that QPGMR wasn't granted authority to the program. Tom
    125,585 pointsBadges:
    report
  • JediK
    TomLiotta thank you,it seems you were right on the money,i have now given QPGMR and QSYS authority to the library that hold the startup program and will test sometime this weekend,once thank you all and chat soon.
    45 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following