SNDTCPSPLF Problem

470 pts.
Tags:
AS/400
AS/400 Spool Files
CLP
IBM iSeries
SNDTCPSPLF
Hello all, I ran into an issue with SNDTCPSPLF.  Here's what the command looks like:
SNDTCPSPLF RMTSYS(LOCALHOST) PRTQ('QUSRSYS/THISOUTQ') +   
             FILE(&SPOOLFILE) JOB(*) SPLNBR(*LAST) +    
             DESTTYP(*AS400) TRANSFORM(*NO) DLTSPLF(*NO)
Where &SPOOLFILE is the name of the spoolfile. The spoolfile gets copied and everything is great.  BUT, the user is changing to QTMPLPD. As far as I know, when you use the command to send to the same system, the SPLF created by the command should be created under the user the job is running on. http://forums.systeminetwork.com/isnetforums/showthread.php?t=39836 This command was working great.  I went through testing for awhile and the correct user was applied.  I stopped testing, came back a week later, and the user is now this QTMPLPD. The user the command is being run under is myself (I.E DCANTWELL) My user profile is not disabled and I had different users try the command.  With the same problem. Any ideas?

Software/Hardware used:
AS400, iSeries, SNDTCPSPLF, CLP,

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hi, the problem occurred here as well since the installation of the latest CUM PTF.
Good news : there is a PTF out to fix it. For V5R4 it is SI42147.

However, we seem to run into issues now that there are not enough ports available.
The messages are

TCP3701 preceded by a TCP100D.

Nothing changed, we just installed the CUM PTF and the fix.

Discuss This Question: 10  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Dcantwell
    The job is getting the user QTMPLPD BTW:
    Job  . . . . . . . . :   QPRTJOB  
      User . . . . . . . :     QTMPLPD
      Number . . . . . . :     396355 
    
    470 pointsBadges:
    report
  • TomLiotta
    I'd review QAUDJRN to see if any odd entries show up during the time a spooled file is received. The problem log might also show something. I also see PTF SI42147 for V5R4, dated Jan 20, 2011, which has me wondering if something hasn't shown up recently, perhaps as a result of previous PTFs. I haven't looked for other releases since I saw that PTF. Tom
    125,585 pointsBadges:
    report
  • Dcantwell
    Looks like it could possible be the PTF issue. It sounds exactly like what the problem is! And literally, the break I took in testing was between that time period. I talked to our systems department about ordering the PTF. I'll let you know how it turns out! Thanks so much for the help!
    470 pointsBadges:
    report
  • Dcantwell
    Got the PTF installed: Problem Fixed. Thanks for the help Tom!
    470 pointsBadges:
    report
  • sahithi6436

    when i use this command SNDTCPSPLF the command looks like this

    SNDTCPSPLF RMTSYS(abc.us.abc) PRTQ(NAHN0PMONQ) FILE(SS@123R1) JOB(068630/NYKBCH/SS@123P) SPLNBR(1)  the spool file name here is SS@123R1 but when the spool file reaches the remote system spool file name is coming as different can i know how can we send the spool file with same name as here

    30 pointsBadges:
    report
  • TomLiotta
    when the spool file reaches the remote system spool file name is coming as different   What kind of system is 'abc.us.abc'?   Tom
    125,585 pointsBadges:
    report
  • chalenger
    I've  got this problem when the remote user isn't found..Hassan
    490 pointsBadges:
    report
  • TheRealRaven
    I’ve  got this problem...   What problem? There are at least two different problems mentioned in this thread so far.   Tom
    35 pointsBadges:
    report
  • chalenger
    I mean when the remote user is not defined , you will get the Splf's under QTMPLPD user..
    490 pointsBadges:
    report
  • TomLiotta
    ...when the remote user is not defined , you will get the Splf’s under QTMPLPD user.   When the original owner does not exist on the remote system, that should be expected. The spooled file needs to be owned by some profile. The alternative would be to fail the transfer.   However, the QTMPLPD can also become the owner on V5R3 or V5R4 if the intended user profile is disabled. This can be changed by PTF. And i 6.1 and 7.1 can each have QTMPLPD become the owner regardles of the status or existence of the intended user. That condition can also be corrected by PTF.   Tom
    125,585 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following