setting up a TRUNK on cisco switch

555 pts.
Tags:
Cisco 2950
Cisco switches
Trunking
I want to know if there is a to combine different subnet on one cisco 2950 switch with trunking ... i have .0, .31. and .9. If someone can give me an example. that would be wonderful. Right now i have one trunk going to the attic switch from the main switch room which is .35.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hi,

If you want to combine different network ,you need a layer 3 device such as a router.Trunking can carry VLAN information between Switches.

Thanks,

Good day! another option in combining different subnets is by using intervlan routing. but here you need a layer 3 device like router.

here is an,example of creating intervlan routing using cisco devices:

Switch:

Switch(config)#vlan 10
Switch(config-vlan)#name subnet1
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name subnet2
Switch(config-vlan)#exit
Switch(config)#int fa0/1
Switch(config-if)#switchport mode trunk ->configuring fa0/1 as a trunk, connected
Switch(config-if)#exit to fa0/0 of the router
Switch(config)#int fa0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10 ->assigning interface 5 to vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/10
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20 ->assigning interface 5 to vlan 20
Switch(config-if)#exit

Router:

Router(config)#int fa0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int fa0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0 -> gateway for subnet1
Router(config-subif)#exit assuming 192.168.10.0/24
Router(config)#int fa0/0.20
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.20.1 255.255.255.0 -> gateway for subnet2
Router(config-subif)#exit assuming 192.168.20.0/24

with this configuration, network from subnet1 can communicate with network on subnet2.

Discuss This Question: 4  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Yasir Irfan
    You can create a trunk port in a Cisco Switch by using following commands, ITKE-Cisco(config)#interface fastEthernet 0/1 ITKE-Cisco(config-if)#switchport trunk encapsulation dot1q ITKE-Cisco(config-if)#switchport mode trunk ITKE-Cisco(config-if)#no shutdown ITKE-Cisco(config-if)# Cheers Yasir
    5,550 pointsBadges:
    report
  • Bhupendra
    my dear, if u really want to share VLAN traffic from one switch to another switch, then u need to configure trunk port between switches b'coz truck carries multi VLAN traffic. And u can create multi VLAN on L2 switches as per the IOS version & ability of the switch. If u want to communicate among inter VLAN means different subnets then u need to have L3 switch to configure inter VLAN. Please feel free to ask any further query & write me for your relevant query. Thanks & Regards, Bhupendra Singh bhupendra_singh007@yahoo.co.in
    205 pointsBadges:
    report
  • 1241256167
    pota
    20 pointsBadges:
    report
  • 1241256167
    mga putang ina nyu gago.....................!!
    20 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following