SAP Webservice consumed by .Net client…ISSUE!!!

5 pts.
Tags:
.NET
SAP PI
SAP WebService
Hi All I have exposed my interface as a webservice and my client is a .net component. Now when i test my client with WS Navigator type tools I recieve proper response. Now as per requirement I tried to absorb the service(SAP PI WebService) in .Net client. Now the issue is while i try getting a response i dont get any message but incase of exceptions i do get them. Just in case of success nothing happens. So we tried 2 override the proxy method to see the response in client side. Now the message that i see tehre is this : "<SOAP:Envelope xmlns:SOAP='http://schemas.xmlsoap.org/soap/envelope/'><SOAP:Header/><SOAP:Body><GetCustomerInformationResponse><GetCustomerInformationResult><?xml version="1.0" encoding="UTF-8"?><GetCustomerInformationResponse Version="1"><CustomerID/><CustomerEmail/><Company><CompanyName>Air Canada</CompanyName><ValidVatNumberIndicator>Constant</ValidVatNumberIndicator><VatNumber>Constant</VatNumber><TaxExemptionIndicator>Constant</TaxExemptionIndicator><TaxExemptionNumber>Constant</TaxExemptionNumber><AirlineDesignator>Constant</AirlineDesignator><HeadquarterCountryCode>Constant</HeadquarterCountryCode><DevelopingNationIndicator>Constant</DevelopingNationIndicator></Company><Addresses><Address><AddressID>Constant</AddressID><AddressTypeCode>Constant</AddressTypeCode><AddressLine1>Constant</AddressLine1><AddressLine2>Constant</AddressLine2><AddressLine3>Constant</AddressLine3><CountryCode>Constant</CountryCode><CountryDescription>Constant</CountryDescription><StateProvinceCode>Constant</StateProvinceCode><StateProvinceDescription>Constant</StateProvinceDescription><City>Constant</City><PostalCode>Constant</PostalCode></Address></Addresses><Customer><CustomerID/><CustomerCategoryCode/><CustomerTypeCode>Air Canada</CustomerTypeCode><CustomerTypeDescription>Air Canada</CustomerTypeDescription><CustomerStatusCode>Air Canada</CustomerStatusCode><FirstName/><MiddleName/><LastName/><Email>Air Canada Center 1235</Email><SalutationCode>H4Y 1H4</SalutationCode><GenderCode>Constant</GenderCode><TelephoneNumber>Constant</TelephoneNumber><TelephoneExtension>Constant</TelephoneExtension><FaxNumber>Constant</FaxNumber><LanguageCode>Constant</LanguageCode><ContactMethodCode>Constant</ContactMethodCode><ProvideInformationIndicator>Constant</ProvideInformationIndicator><ClearingHouseIndicator>Constant</ClearingHouseIndicator><JobTitle>Constant</JobTitle><JobLevelCode>Constant</JobLevelCode><JobFunctionCode>Constant</JobFunctionCode><DepartmentCode>Constant</DepartmentCode></Customer><Status><Number>Constant</Number><Description>Constant</Description></Status></GetCustomerInformationResponse></GetCustomerInformationResult></GetCustomerInformationResponse></SOAP:Body></SOAP:Envelope>" Ideally before the Soap Envelope i should have this tag too : <?xml version="1.0" encoding="utf-8"?> . I get this when i test it with WS navigator and all but i cant get this when i receive the response for .Net client which leds to me not recieving any response atall but a success message at SAP adapter side. Kindly provide some inputs on the same if possible... Thanks in Advance !!!
ASKED: June 26, 2009  1:16 PM
UPDATED: June 26, 2009  2:25 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following