RPG Program works fine in debug (ISDB)

15 pts.
Tags:
ISDB
RPG
RPG Program
RPG/400
V5R4
I am coding a program in RPG/400 on OS v5r4. The program uses input files to calculate several program described fields for a report. The program does not calc correctly when I call it from the command line. The program works as expected when I run it through debug (ISDB). I am using the same sign on with the same library list in both cases. Has anyone else run into this problem? Also, I cleared the copies of my objects from QRPLOBJ and the system has gone through an IPL - still the same results. Thanks. - chris - cblooding@yahoo.com

Answer Wiki

Thanks. We'll let you know when a new response is added.

Chris
Never experienced it .. but haven’t used ISDB in a long while.

do you pass any parameters on the Call?
If so send us your call and the *ENTRY plist

Phil
//////////////////////

Strange things?
Everyday of my life… but not particularly related to computers.

Phil

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Flydragon
    I do pass parameters. BUT, I just called the program outside of debug and it is working fine, now. I've made absolutely no changes. Didn't even recompile since the last time I called it a week ago, when it didn't work. I really feel like it is an OS issue. I've experienced weird things with compiling/calling my programs since the OS was upgraded last summer from v5r3 to v5r4. Anyone else experience strange things with v5r4 and RPG?
    15 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following