SQL Server 2008 Restore Fails – There is insufficient system memory in resource pool ‘internal’ to run this query

20 pts.
Tags:
SQL Query
SQL Server 2008
SQL Server 2008 error messages
SQL Server database restore
SQL Server restore
I am trying to restore from a backup to a new database, and it processes for 8 hours and completes to 100%, and i get the following error.

100 percent processed. Msg 3013, Level 16, State 1, Line 1 RESTORE DATABASE is terminating abnormally. Msg 701, Level 17, State 123, Line 1 There is insufficient system memory in resource pool 'internal' to run this query.

I cannot access the database as it goes into recovery mode. Does anyone have any suggestions as to how I can get a successful restore from my backup and why it is failing on this. I'm using SQL Server 2008

 Thanks in advance. MT



Software/Hardware used:
SQl server 2008

Answer Wiki

Thanks. We'll let you know when a new response is added.

How much memory does the SQL Instance have allocated to it? Are you restoring the database from a network share or the local disk?

Discuss This Question: 4  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • MTLONDON
    Hi Mrdenny Thanks for reply How can I find out SQL Instance memory on sever. I'm restoring from local disk. MT
    20 pointsBadges:
    report
  • Pherschel
    some have had success with using the -g option when starting SQL Server. -g384 I had luck with: EXEC sys.sp_configure N'max server memory (MB)', N'512'
    10 pointsBadges:
    report
  • Ramu241911
    that is not a problem of restore...u should clear all the space of using memory and clear all the unwanted backup files ...after restore it will work...
    10 pointsBadges:
    report
  • RAJGUJAR
    I had the same problem , tried quite a few option on the web. Then Delete all the Backup devices on the source , recreated the backup and restored it on the Target. Everything worked fine. In my case It could be a back backup file. R A J
    10 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following