report server error using oracle 10g

15 pts.
Tags:
Oracle 10g
Oracle error messages
Oracle Reports
Hi. I an using oracle 10g. when i run 10g reports individually it works fine but when i try it to connect with forms it gives error 'cannot connect toserver' please help how could i connect it to server.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Where are you trying to run this report, AS or local machine?
Just to clarify you need a report server in local machine or report services to run the report through forms, both have different method to start.

What I think is you are trying to call the report in your machine (Window based). Here how you create and start a report server in your machine.

From the dos command window (go to the following path or run the file with the path)

<pre><Oracle DS Home>/bin/rwserver server=<server_name> [batch=yes/no] [autostart=yes/no]</pre>

For batch, the default is no. Enter yes if you don’t want to be prompted for confirmation during installation. For autostart, the default is no. Enter yes if you want the service to start automatically at reboot without requiring a user to logon and manually start the Reports Server.

Confirm that report server is running, run the following URL

<pre>http://<your_machine_name>.<domain_name>:<your_port_number>/reports/rwservlet/showjobs?</pre>

Usually if the its a local machine and not on the network the URL could be

<pre>http://127.0.0.1:8888/reports/rwservlet/showjobs?</pre>

Good luck

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Kelp
    Hi, You have mentioned the procedure to start report server, but i want to know how to start the report service also. Further i want to know that after start report server, how can i know that the report server is running ? I want to run my report from forms and all are installed on one machine. I tried to run my report from forms, but i get the error that "UNABLE TO RUN REPORT". I am using RUN-REPORT_OBJECT builtins. Waiting for reply. Thanking you, -Kelp
    115 pointsBadges:
    report
  • Kelp
    Dear Fhashmat, I have explain my query earlier and i am waiting for the reply. Please reply me as soon as possible, Thanks.
    115 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following