Problems running AS400 stored procedure from SQLServer 2005 SSIS execute SQL task

15 pts.
Tags:
AS/400 SQL
AS/400 SSIS
AS/400 stored procedures
SQL Server 2005
I need to run a stored procedure (with two input parameters ) that has no output, on an AS400. When I try using the IBM DB2 UDB for iSeries IBMDA400 OLE DB provider, I get the following error [Execute SQL Task] Error: Executing the query "CALL TPSDTA50GQ.PMCTESTTP('PETER', 4)" failed with the following error: "TPSDTA50GQ.PMCTESTTP is an undefined name. SQLSTATE: 42704, SQLCODE: -204". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly. However I can run the same SQL on the AS400 successfully. Peter

Software/Hardware used:
SQLServer 2005 SSIS AS400 iSeries Drivers
ASKED: August 23, 2010  8:09 PM
UPDATED: August 24, 2010  2:01 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • TomLiotta
    Unless we see at least the CREATE PROCEDURE statement and the code that calls it, there's no way we can guess. Please post the code for both. Tom
    125,585 pointsBadges:
    report
  • PeterJC
    Tom, Thanks for the interest. Its working now, after fixing 2 issues. 1. getting the security on the AS400 set up so the SSIS user could see the stored proc. 2 using the IBM DB2 UDB for iSeries IBMDASQL OLE Provider instead of IBM DB2 UDB for iSeries IBMDA400 OLE Provider Peter
    15 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following