Problem with highlighting a program or JCL

5 pts.
Tags:
COBOL
JCL
Lenovo terminal
I am a COBOL developer, and I've got a new terminal (Lenovo) yesterday. I have a problem: I cannot highlight a COBOL program or JCL in the TSO. I type command "HI" in the command line, but instead of getting the next screen with highlight options, I am getting the error message "Invalid terminal" in the upper right corner. If I press PF1 (Help) key then, I have further explanation which says: "Enhanced coloring is not available on this terminal because the terminal does not support extended highlighting." Can you suggest anything to fix this? FYI: In the settings I have Terminal Type 3278. Your help is greatly appreciated. Thanks

Answer Wiki

Thanks. We'll let you know when a new response is added.

You are a COBOL developer and you are using ISPF running under TSO – (at least I hope you aren’t using the old TSO line editor, yuck)

On the ISPF EDIT command line, you issue the HILITE command and get an error message claiming your terminal will not support enhanced coloring. Your terminal settings are most likely wrong. your TERMINAL settings, not ISPF, not TSO. Your TERMINAL EMULATION settings is where I would start.

By the way, HILITE is one of the settings in your ISPF PROFILE. I have a profile for COBOL, so when I am editting a PDS whose name ends in .COBOL (e.g. userid.DEV.COBOL) the ISPF PROFILE named COBOL is activated with all of the settings required for COBOL (e.g. NUMBER ON COBOL, CAPS ON) and when I am editting an ASSEMBLER program from a PDS whose name ends with ASM the ISPF PROFILE named ASM is active with things like HILITE ASM. You should look into it, but first get your PC to terminal emulation settings defined.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Abhinaya

    Try "HI COB".

    Should work

    10 pointsBadges:
    report
  • TheRealRaven
    Is your terminal emulator using 'extended telnet'? That's required for receiving and displaying highlight attributes.
    18,995 pointsBadges:
    report
  • ToddN2000
    How is you emulator configured? I think Raven's idea will take care of the issue.
    49,275 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: