Problem with EtherChannel

15 pts.
Tags:
Cisco
Cisco switches
EtherChannel
Network connectivity
Switch configuration
Switches
Hi everyone I have configured etherchannel on two cisco switches and have enabled on mode. The problem I am having is that the etherchannel link disconnects from time to time for about 5-6sec then comes back on. The wierd thing is that when I display the logging history I get some pagp messages (pagp should be off when on mode is enabled). Below is the messages that I am getting. pagp_switch_hotstandby: PAgP not enabled on agport Po10 3w1d: FEC: pagp_switch_port_down: Fa0/15 Inform yes 3w1d: FEC: pagp_switch_invoke_port_down: Fa0/15 3w1d: FEC: fec_unbundle: Fa0/15 3w1d: FEC: pagp_switch_change_vgc: gcchngreq == 0 for Fa0/15 3w1d: FEC: pagp_switch_change_vgc: Fa0/15 gcchngreq = 0 gc = 0 3w1d: FEC: pagp_switch_delete_port_from_agport_internal: delete_port_from_agport: for port Fa0/15 3w1d: FEC: delete port (Fa0/15) from agport (Po10) 3w1d: FEC: pagp_switch_delete_port_from_agport_list: afb->nports-- = 1 [Fa0/15] 3w1d: FEC: Un-Bndl msg NOT send to PM for port Fa0/15 from Po10 3w1d: FEC: pagp_switch_reset_load_index: reading load-index for port Po10 3w1d: FEC: pagp_switch_hotstandby: for agport Po10 3w1d: FEC: pagp_switch_hotstandby: PAgP not enabled on agport Po10 3w1d: FEC: pagp_switch_port_down: Fa0/16 Inform yes 3w1d: FEC: pagp_switch_invoke_port_down: Fa0/16 3w1d: FEC: fec_unbundle: Fa0/16 3w1d: FEC: pagp_switch_change_vgc: gcchngreq == 0 for Fa0/16 3w1d: FEC: pagp_switch_change_vgc: Fa0/16 gcchngreq = 0 gc = 0 3w1d: FEC: pagp_switch_delete_port_from_agport_internal: delete_port_from_agport: for port Fa0/16 3w1d: FEC: delete port (Fa0/16) from agport (Po10) 3w1d: FEC: pagp_switch_delete_port_from_agport_list: afb->nports-- = 0 [Fa0/16] 3w1d: FEC: Un-Bndl msg NOT send to PM for port Fa0/16 from Po10 3w1d: FEC: pagp_switch_reset_cannot_bundle_ports: group 10 3w1d: FEC: pagp_switch_reset_cannot_bundle_ports: group 10 .Oct 22 10:11:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/15, changed state to down .Oct 22 10:11:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to down .Oct 22 10:11:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel10, changed state to down Can anyone explain to me why am I getting these messages and what can I do to solve this problem. Thanks in advance for your help.

Answer Wiki

Thanks. We'll let you know when a new response is added.

HI,
Can you supply the following

show run int po10
show run int fa0/15
show run int fa0/16
============================
You supplied the show int , I asked for the show run int, which will display the commands you have configured.

show run int po10
show run int fa0/15
show run int fa0/16

I would assume, you have channel-group pagp command under an interface

When I setup etherchannel, I use the following config. This example uses a Port channel of 1 assigned int VLAN 10 and two interfaces fa0/1 and fa0/2 for links in the bundle.

int po1
description Etherchannel_Bundle
speed 100
duplex full
switchport mode access
switch access vlan 10
no shut

int fa0/1
description Po1_Link1
speed 100
duplex full
switchport mode access
switchport access vlan 10
channel-group 1 mode on

int fa0/2
description Po1_Link2
speed 100
duplex full
switchport mode access
switchport access vlan 10
channel-group 1 mode on

=============================================
If you plan on making the bundle a trunk then the following will work if you are using vlan 10 and 11

interface Port-channel1
description ehterchannel_Trunk
switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work)
switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk
switchport mode trunk

interface fa0/1
description Po1_link1
switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work)
switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk)
switchport mode trunk
speed 1000
duplex full
channel-group 1 mode on

interface fa0/2
description Po1_link2
switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work)
switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk)
switchport mode trunk
speed 1000
duplex full
channel-group 1 mode on

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Mstefo
    Here is the output for the show commands: show run int po10 Port-channel10 is up, line protocol is up (connected) Hardware is EtherChannel, address is 001a.e387.5691 (bia 001a.e387.5691) MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, reliability 255/255, txload 15/255, rxload 43/255 Encapsulation ARPA, loopback not set Keepalive set (10 sec) Full-duplex, 100Mb/s, link type is auto, media type is unknown input flow-control is off, output flow-control is unsupported Members in this channel: Fa0/15 Fa0/16 ARP type: ARPA, ARP Timeout 04:00:00 Last input 09:33:11, output 00:00:00, output hang never Last clearing of "show interface" counters never Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max) 5 minute input rate 34131000 bits/sec, 4917 packets/sec 5 minute output rate 11800000 bits/sec, 4404 packets/sec 328460894 packets input, 274992592076 bytes, 0 no buffer Received 103575 broadcasts (6870 multicasts) 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 0 watchdog, 6870 multicast, 0 pause input 0 input packets with dribble condition detected 295355066 packets output, 101031472649 bytes, 0 underruns 0 output errors, 0 collisions, 1 interface resets 0 babbles, 0 late collision, 0 deferred 0 lost carrier, 0 no carrier, 0 PAUSE output 0 output buffer failures, 0 output buffers swapped out show int f0/15 FastEthernet0/15 is up, line protocol is up (connected) Hardware is Fast Ethernet, address is 001a.e387.5691 (bia 001a.e387.5691) Description: "Trunk-to-Tarabosh" MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, reliability 255/255, txload 12/255, rxload 91/255 Encapsulation ARPA, loopback not set Keepalive set (10 sec) Full-duplex, 100Mb/s, media type is 10/100BaseTX input flow-control is off, output flow-control is unsupported ARP type: ARPA, ARP Timeout 04:00:00 Last input 00:00:27, output 00:00:01, output hang never Last clearing of "show interface" counters never Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max) 5 minute input rate 35795000 bits/sec, 5115 packets/sec 5 minute output rate 4722000 bits/sec, 1900 packets/sec 328689381 packets input, 275622214308 bytes, 0 no buffer Received 102677 broadcasts (3025 multicasts) 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 0 watchdog, 3025 multicast, 0 pause input 0 input packets with dribble condition detected 70509705 packets output, 33266415826 bytes, 0 underruns 0 output errors, 0 collisions, 1 interface resets 0 babbles, 0 late collision, 0 deferred 0 lost carrier, 0 no carrier, 0 PAUSE output 0 output buffer failures, 0 output buffers swapped out show int f0/16 FastEthernet0/16 is up, line protocol is up (connected) Hardware is Fast Ethernet, address is 001a.e387.5692 (bia 001a.e387.5692) Description: "Trunk-to-Tarabosh" MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, reliability 255/255, txload 19/255, rxload 1/255 Encapsulation ARPA, loopback not set Keepalive set (10 sec) Full-duplex, 100Mb/s, media type is 10/100BaseTX input flow-control is off, output flow-control is unsupported ARP type: ARPA, ARP Timeout 04:00:00 Last input 00:00:20, output 00:00:00, output hang never Last clearing of "show interface" counters never Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max) 5 minute input rate 13000 bits/sec, 8 packets/sec 5 minute output rate 7612000 bits/sec, 2715 packets/sec 575938 packets input, 82631567 bytes, 0 no buffer Received 1139 broadcasts (3940 multicasts) 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 0 watchdog, 3940 multicast, 0 pause input 0 input packets with dribble condition detected 225627719 packets output, 68026757508 bytes, 0 underruns 0 output errors, 0 collisions, 1 interface resets 0 babbles, 0 late collision, 0 deferred 0 lost carrier, 0 no carrier, 0 PAUSE output 0 output buffer failures, 0 output buffers swapped out Thanks in advance for your help
    15 pointsBadges:
    report
  • Jmflanag
    You supplied the show int , I asked for the show run int, which will display the commands you have configured. show run int po10 show run int fa0/15 show run int fa0/16 I would assume, you have channel-group pagp command under an interface When I setup etherchannel, I use the following config. This example uses a Port channel of 1 assigned int VLAN 10 and two interfaces fa0/1 and fa0/2 for links in the bundle. int po1 description Etherchannel_Bundle speed 100 duplex full switchport mode access switch access vlan 10 no shut int fa0/1 description Po1_Link1 speed 100 duplex full switchport mode access switchport access vlan 10 channel-group 1 mode on int fa0/2 description Po1_Link2 speed 100 duplex full switchport mode access switchport access vlan 10 channel-group 1 mode on ============================================= If you plan on making the bundle a trunk then the following will work if you are using vlan 10 and 11 interface Port-channel1 description ehterchannel_Trunk switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work) switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk switchport mode trunk interface fa0/1 description Po1_link1 switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work) switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk) switchport mode trunk speed 1000 duplex full channel-group 1 mode on interface fa0/2 description Po1_link2 switchport access vlan 10 (native VLAN that doesnt get tagged, if trunk fails this VLAN will still work) switchport trunk allowed vlan 10,11 (allows only specifc VLANs on the trunk) switchport mode trunk speed 1000 duplex full channel-group 1 mode on
    230 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following