Port Forwarding with Cisco 3560

5 pts.
Tags:
Cisco
Cisco 3560
L3 Switches
Layer 3
Layer 3 switches
Network administration
Port 445
Port 80
Port forwarding
SMB over IP
Switch configuration
Switches
Hi Friends, I have a small requirement. please see my configuration. i have an L3 switch (Cisco 3560) series and now i am forwarding all the traffic from my network to Firewall from L3 switch through this default route " ip route 0.0.0.0 0.0.0.0 10.11.12.2" where 10.11.12.1 is my L3 switch 10.11.12.2 is my firewall 10.11.12.3 is my ISA server now my requirement is... i want to redirect ports 80 and 445 to 10.11.12.3(ISA server) instead of going to 10.11.12.2 (Firewall). please let me know what configuration needs to be added.

Answer Wiki

Thanks. We'll let you know when a new response is added.

You can do this by applying PBR (Policy Based Routing). See below a very simple config. You can amend the PBR rules in below ACL

<b>1. Define your PBR rule ACL </b>

<pre><pre>ip access-list extended PBR
permit ip any any eq 80
permit ip any any eq 445</pre>

<b>2. Define next hop</b>

<pre>route-map PBR permit 10
match ip address PBR
set ip next-hop 10.11.12.3</pre>

<b>3. Apply the PBR on L3 inteface(s) </b>

e.g.

<pre>interface Vlan 11
description Users subnet 10.11.11.0/24
ip address 10.11.11.1 255.255.255.0
ip policy route-map PBR

interface Vlan 12
description subnet 10.11.12.0/24
ip address 10.11.12.1 255.255.255.0
ip policy route-map PBR</pre>

<b>4. Optional: </b>
Apply the below config. if you want to apply PBR on all the local traffic generated from L3 switch itself.

<pre>ip local policy route-map PBR</pre></pre>

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following