need help with cme 4.x on 2801 (bri connection)

20 pts.
Tags:
Cisco 2801
ISDN
VoIP
Hi all!!! I`ve got overhellming my head problem. I managed to set up voip network with AA and voicemail, now i want conections for outside calls throught ISDN (bri) interface. I can call out but when call is picked up no sound is heard at all. I do also have the same problem for inbound calls. Can provide debug or running config if needed. Please halp.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Here is my runing config:
<pre>
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone eet 0 2
network-clock-participate wic 3
network-clock-select 1 BRI0/3/1
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.2
!
ip dhcp pool VOICE
network 192.168.10.0 255.255.255.0
option 150 ip 192.168.10.1
default-router 192.168.10.1
!
ip dhcp pool DATA
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
dns-server 10.1.0.61
!
!
no ip domain lookup
multilink bundle-name authenticated
!
isdn switch-type basic-net3
isdn logging
!
voice-card 0
!
!
voice rtp send-recv
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 10
rule 1 /817455260/ /1001/
!
voice translation-rule 20
rule 1 /100./ /817455260/
!
!
voice translation-profile IN
translate called 10
!
voice translation-profile OUT
translate calling 20
!
!
!
!
!
!
username cisco password 0 cisco
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Service-Engine0/0
ip unnumbered Vlan10
service-module ip address 192.168.10.2 255.255.255.0
service-module ip default-gateway 192.168.10.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1/0
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/1/1
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/1/2
switchport access vlan 10
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface BRI0/3/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn voice-priority always
isdn incoming-voice voice
!
interface BRI0/3/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn voice-priority always
isdn incoming-voice voice
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 192.168.10.2 255.255.255.255 Service-Engine0/0
!
!
ip http server
no ip http secure-server
ip http path flash:
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.100.0 0.0.0.255
access-list 22 permit 192.168.10.4 log
!
!
tftp-server flash:P0030702T023.bin
tftp-server flash:apps11.8-2-2ES1.sbn
tftp-server flash:cnu11.8-2-2ES1.sbn
tftp-server flash:cvm11sccp.8-2-2ES1.sbn
tftp-server flash:dsp11.8-2-2ES1.sbn
tftp-server flash:jar11sccp.8-2-2ES1.sbn
tftp-server flash:SCCP11.8-2-2SR1S.loads
tftp-server flash:term11.default.loads
!
control-plane
!
!
!
voice-port 0/3/0
no vad
compand-type a-law
cptone PL
connection plar 1001
!
voice-port 0/3/1
no vad
compand-type a-law
cptone PL
connection plar 1001
!
!
!
!
!
dial-peer voice 10 voip
destination-pattern 1…
session protocol sipv2
session target ipv4:192.168.10.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 100 pots
translation-profile outgoing OUT
destination-pattern 0………
direct-inward-dial
port 0/3/1
forward-digits all
!
dial-peer voice 200 pots
translation-profile incoming IN
incoming called-number 817455260
direct-inward-dial
port 0/3/1
!
!
!
telephony-service
sdspfarm units 1
load 7960-7940 P0030702T023
load 7911 SCCP11.8-2-2SR1S
max-ephones 20
max-dn 20
ip source-address 192.168.10.1 port 2000
timeouts interdigit 5
cnf-file location flash:
cnf-file perphone
voicemail 1111
max-conferences 4 gain -6
moh music-on-hold.au
web admin system name eeKyy password eeKyy
web admin customer name eeKyy1 password eeKyy1
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Jul 04 2008 12:17:25
!
!
ephone-dn 1 dual-line
number 1001
description PIERWSZY
name PIERWSZY
call-forward busy 1111
call-forward noan 1111 timeout 10
!
!
ephone-dn 2 dual-line
number 1002
description DRUGI
call-forward busy 1111
call-forward noan 1111 timeout 10
!
!
ephone-dn 3 dual-line
number 1003
description IPcommunicator
call-forward busy 1111
call-forward noan 1111 timeout 10
!
!
ephone-dn 18
number 1998….
mwi on
!
!
ephone-dn 19
number 1999….
mwi off
!
!
ephone 1
mac-address 001B.D512.B246
type 7940
button 1:1
!
!
!
ephone 2
mac-address 001A.6D5C.49CF
type 7911
button 1:2
!
!
!
ephone 3
username “user3″ password 1234
mac-address 0030.4F26.E0C7
type CIPC
button 1:3
pin 1111
!
!
!
line con 0
logging synchronous
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
scheduler allocate 20000 1000
ntp master
ntp server 192.168.10.1
end
</pre>

<pre>
debug isdn q931:
Router#debug isdn q931
debug isdn q931 is ON.
Router#
Jul 4 13:08:22.331: ISDN BR0/3/1 Q931: Applying typeplan for sw-type 0×1 is 0×0 0×0, Calling num 817455260
Jul 4 13:08:22.335: ISDN BR0/3/1 **ERROR**: handle_l2d_srq_mail: Layer 1 inactive
Router#
Jul 4 13:08:22.387: %LINK-3-UPDOWN: Interface BRI0/3/1, changed state to up
Jul 4 13:08:22.531: %MARS_NETCLK-3-CLK_TRANS: Network clock source transitioned from priority 11 to priority 1
Router#
Jul 4 13:08:24.559: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0/3/1, TEI 90 changed to up
Router#
Jul 4 13:08:24.563: ISDN BR0/3/1 Q931: TX -> SETUP pd = 8 callref = 0×07
Bearer Capability i = 0x8090A3
Standard = CCITT
Transfer Capability = Speech
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0×81
Preferred, B1
Progress Ind i = 0×8183 – Origination address is non-ISDN
Calling Party Number i = 0×0080, ’817455260′
Plan:Unknown, Type:Unknown
Called Party Number i = 0×80, ’0509544354′
Plan:Unknown, Type:Unknown
Jul 4 13:08:24.787: ISDN BR0/3/1 Q931: RX <- SETUP_ACK pd = 8 callref = 0×87
Channel ID i = 0×89
Exclusive, B1
Router#
Jul 4 13:08:33.447: ISDN BR0/3/1 Q931: RX <- CALL_PROC pd = 8 callref = 0×87
Progress Ind i = 0×8288 – In-band info or appropriate now available
Jul 4 13:08:33.975: ISDN BR0/3/1 Q931: RX <- ALERTING pd = 8 callref = 0×87
Router#
Jul 4 13:08:40.891: ISDN BR0/3/1 Q931: RX <- CONNECT pd = 8 callref = 0×87
Facility i = 0x91A15102022D5002011F3048301E0A0100A11981032E2E2EA206810164820101830101A40781020C9882010030120A0102A20D81032E2E2EA20681010082010130120A0104A20D81032E2E2EA206810100820101
Protocol Profile = Remote Operations Protocol
0xA15102022D5002011F3048301E0A0100A11981032E2E2EA206810164820101830101A40781020C9882010030120A0102A20D81032E2E2EA20681010082010130120A0104A20D81032E2E2EA206810100820101
Component = Invoke component, Unsupported operation
Display i = ‘FIX: 1 PERIOD: 0:00:32 – 1′
Date/Time i = 0x0807040D0A
Jul 4 13:08:40.895: %ISDN-6-CONNECT: Interface BRI0/3/1:1 is now connected to 0509544354 N/A
Router#
Jul 4 13:08:40.895: ISDN BR0/3/1 Q931: TX -> CONNECT_ACK pd = 8 callref = 0×07
Jul 4 13:08:40.919: ISDN BR0/3/1 Q931: RX <- FACILITY pd = 8 callref = 0×87
Facility i = 0x91A11302022D51020122300AA1053003020101820100
Protocol Profile = Remote Operations Protocol
0xA11302022D51020122300AA1053003020101820100
Component = Invoke component
Invoke Id = 11601
Operation = AOCDChargingUnit
Router#
Jul 4 13:08:50.831: ISDN BR0/3/1 Q931: RX <- INFORMATION pd = 8 callref = 0×87
Display i = ‘LICZBA JEDNOSTEK – 1′
Router#
Jul 4 13:08:53.087: %DSMP-3-DSP_TIMEOUT: DSP timeout on DSP 0/5:1: event 0xDC, DSMP timed out, while waiting for statistics from the DSP. DSMP State = S_DSMP_COLLECTING_STATS, chnl info(0, 5, 1)
Jul 4 13:08:53.087: %ISDN-6-DISCONNECT: Interface BRI0/3/1:1 disconnected from 0509544354 , call lasted 12 seconds
Jul 4 13:08:53.087: ISDN BR0/3/1 Q931: TX -> DISCONNECT pd = 8 callref = 0×07
Cause i = 0×8090 – Normal call clearing
Jul 4 13:08:53.175: ISDN BR0/3/1 Q931: RX <- DISCONNECT pd = 8 callref = 0×87
Cause i = 0×8090 – Normal call clearing
Facility i = 0x91A11202022D5202012430093007A1053003020101
Protocol Profile = Remote Operations Protocol
0xA11202022D5202012430093007A1053003020101
Component = Invoke component
Invoke Id = 11602
Operation = AOCECharging Unit
Progress Ind i = 0×8288 – In-band info or appropriate now available
Display i = ‘LICZBA JEDNOSTEK – 1′
Jul 4 13:08:53.179: ISDN BR0/3/1 Q931: TX -> RELEASE pd = 8 callref = 0×07
Router#
Jul 4 13:08:53.191: ISDN BR0/3/1 Q931: RX <- RELEASE pd = 8 callref = 0×87
Router#
</pre>

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following