Boot failure with Dell Latitude 600

5 pts.
Tags:
Boot failure
Dell Latitude 600
I have a problem with my dell 600 latitude. I have a working power supply but when I plug it in it will not work. I have also checked by removing my battery and just using just the power supply but it still will not boot. Anyone know what could be wrong?

Answer Wiki

Thanks. We'll let you know when a new response is added.

Sounds to me like a failing system board.

I would first exercise the connections on the system board and see if any of those don’t look right.

Then I would check the battery on the system board.

I would also check to see if there is anything physically wrong with the port to which the power adapter plugs in, as there may be some connection not being made…a quick check is this: plug it in, with the battery in it. if a light comes on indicating the battery is charging, or is charged, then there is nothing wrong with the port and the traces between the input and the battery. Unfortuneately, this doens’t necessarily rule out system board.

Hope this helps!

-Schmidtw

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • PC32Mech
    Hello. Are you sure your power supply works well? It turns the alternating current into direct current (AC to DC). There exists the probability of which you have checked your device with a tester of electrical voltaje and which this one indicates that the voltage is correct. Nonetheless, it is not possible to know with this if the electrical current is really filtered. That is to say, it is a really DC current ? If your computer no boot. Just try whitout the power supply. If after this it starts, you supply does not work. Your Dell 600 Latitude never boot if the voltage and current is not correct and stable. Regards!
    45 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following