Lost system after reorganize

430 pts.
Tags:
AS400 - JOB LOG
I lost the system no user can login after I delete some file and ask me to reorganize files .. no operator I'd want to sign in after that

Software/Hardware used:
norwat ticketing system

Answer Wiki

Thanks. We'll let you know when a new response is added.

i reorganize file because after i delete records the application asked me to do so 

i think that the problem in job logs the job logs has been deleted 
is there a way to restore the pervious job logs 

Discuss This Question: 24  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • TomLiotta
    More information is needed. Can any user profile sign on? (QSECOFR? QSYSOPR?) Do users see 'Sign On' screens? What happens when users try to sign on? Can you connect with Operations Navigator? -- Tom
    125,585 pointsBadges:
    report
  • TomLiotta
    Also, what file was deleted? And what does "ask me to reorganize files" mean? Please describe it more. -- Tom
    125,585 pointsBadges:
    report
  • philpl1jb
    What types of backups were made on what dates?
    50,585 pointsBadges:
    report
  • abar1
    we have 2 security screen .. the user is signed to the first one normally , when we come to the application screen operator id and password , it ask for the password again and again .. no backup cause we dicovered that the tape backup was not working instead it was backing up normally by the way i dont need any of the privious data i just need to get back the system ... the qsecofr is signed in normally ... i did reorganize to the file cause it says that the file was full "cant add record" i deleted the records but it ask me to close the customs file and reorganize i end all jobs and get out all log off all users and pressed continue 
    430 pointsBadges:
    report
  • abar1
    i just made a copies of the libraries before reorganize when i restored it ,, the system remain the same 
    430 pointsBadges:
    report
  • abar1
    i tried to ipl no change ... i copied  the old library again during ipl but it never works 
    430 pointsBadges:
    report
  • abar1
    when i use the wrkjob command i find all the history of all subsystems and users but they are not active 
    430 pointsBadges:
    report
  • abar1
    any help ??????????
    430 pointsBadges:
    report
  • TomLiotta
    The situation is getting less clear. You started with "lost system", and now the system seems to be running fine, but some application is having trouble. The trouble is not clearly described.   Apparently, some users sign on okay because you can see results in the system. But you also say this:   when we come to the application screen...   But we have no idea what you mean by "application screen". What is an "application screen" and what does it have to do with an "operator id and password"?   As far as I can tell from the description so far, you have an application problem, not a system problem. You need to debug the application. If there are errors in joblogs, we need to see the error messages.   We don't know anything about the file except that it needed to be extended and you decided to reorganize it. We don't know why you reorganized. We don't know what the file was, how big it was, how many files were related to it. We don't know why an "application" is asking for a password. We don't know what the application is.   It sounds like you need your programmers to work on it. There doesn't seem to be anything we can do to help without a much better description of what's going on.   Tom
    125,585 pointsBadges:
    report
  • abar1
    of course i knew that it is an application problem but i just asked is there a way to reclaim what happened ... or to undo it 
    430 pointsBadges:
    report
  • TomLiotta
    i reorganize file because after i delete records the application asked me to do so   First, please use the 'Discuss' area rather than the 'Answer' area to add comments. It's too easy to miss 'Answer' comments, and 'Answer' comments might be changed or removed by later entries.   Originally, you said you deleted a file; but here you said you deleted records. Which was it? File or just records?   Later, you said:   i just made a copies of the libraries before reorganize when i restored it   Did you restore the file that you reorganized? That shouldn't have been necessary, and it might be a problem if the backup was out of date. Is the file journaled? You haven't described what the file is yet, though you mentioned a "customs" file at one point. (And you haven't told what the application is. That doesn't help us to understand the problem. It's not clear at all why an application would ask you to reorganize a file. That's very unusual.)   Joblogs shouldn't be a problem. A user should be able to get a new joblog today. Old ones aren't necessary. We're trying to learn what is happening now, before figuring out how it might be fixed.   Tom
    125,585 pointsBadges:
    report
  • abar1
    The problem again , i needed to delete some old performance ,, i go to delete menue , i choosed the performances to be deleted ,,, it ask me to reorganize to apply the delete i had to accept ... 
    i did ... all the performances deleted the (marked one and the non marked one)
    i tried to resotre the transaction library "prlansys" from the copy i did before deletion ... since that time no operator can sign in ... 
    The security users only can sign in to the iseries menu (such as qsecofr, .....) 
    the application name is norwat entertainment system .. from combridge software inc. Canada 

    430 pointsBadges:
    report
  • TomLiotta
    This has become more confusing.   The problem again , i needed to delete some old performance   That isn't the "problem again". This is the first time you have mentioned deleting 'performance'. What does that mean? What is "performance"?   Are you deleting old performance "data"? Is this data from system performance tools? Or is it data stored by your application?   i go to delete menue   What "delete menue"? Is that for deleting Performance Tools collections? Or is it an application menu?   i choosed the performances to be deleted ,,, it ask me to reorganize to apply the delete i had to accept …    This is a confusing part. I don't remember seeing any references to reorganizing when I've deleted performance data. It might do it; I'm only saying that I can't remember seeing it. I don't use Performance Tools anymore.   Do you know what was reorganized?   all the performances deleted the (marked one and the non marked one)   Does that mean that all of your performance data disappeared? Even collections that you didn't ask to delete are gone? (Or is this application data?)   i tried to resotre the transaction library “prlansys” from the copy i did before deletion   Now it's again confusing. What is library PRLANSYS? Is that where you store performance collections? Or is it an application library? Why did you decide to restore it?   since that time no operator can sign in … The security users only can sign in to the iseries menu   Are "operators" your normal users? If some users (e.g., QSECOFR) can sign on normally, but other users with less authority can't, then it's probably an authority problem. PRLANSYS might be an application library that users need. If it was restored without its authorities, then users might be locked out.   The problem is more confusing, but it might be possible to find an answer now. Have a user try to sign on. After it fails, have a security user look in the system audit journal (QAUDJRN) for 'AF' authority failure entries at the time of the failed logon. If there are no 'AF' entries, look for other entries that indicate a problem.   Tom
    125,585 pointsBadges:
    report
  • abar1
    Performance means "opera Shows" so i deleted old shows  from the schedule. after choosing shows to be deleted it asked me to press f5 to reorganize to reorganize what?? i didnt know but i had to do it i did the delete menu of course is in the application menu all what had happened is in the application not related to operating system One thing that i found today after IPL which was related to the system, a message says "groce period expired >> requested user can not be added"  
    430 pointsBadges:
    report
  • abar1
    unfortunately , no user can logon to the application even qsecofr ,,, qsecofr only login to the iseries main menu ... if we try to use qsecofr to login to application it ask for the operator id and password ,,, and failed 
    430 pointsBadges:
    report
  • TomLiotta
    Performance means “opera Shows” so i deleted old shows  from the schedule.   AH! Entertainment. Performances. Programs. Shows! Now a lot more makes sense. I apologize for being slow on that. The words kept meaning something else to me. Now I can understand why the "application" could have prompted you to reorganize.   When you reorganized, did you type the RGZPFM command yourself on a command line, or did the application present you with a reorganize option?   When you restored, did you use the RSTLIB command? Do you remember if you used the ALWOBJDIF(*ALL) parameter?   Do you know if you have the IBM PDM product on your system? The restored library might have made unexpected changes to your files. The parameters that you specified are important, and PDM might make it easier to see if existing physical files were renamed.   Tom
    125,585 pointsBadges:
    report
  • abar1
    Thank you Mr. Tom for concerning about my Problem , Just want to tell you that this system is the reservation system of the Cairo opera house , Egypt . Unfortunately , the previous director didn't tell us any documentation about this system , he died suddenly in an surgical operation , i don't have  any previous experience in working with  as400 or iseries. That may be the cause that i can not explain the problem clearly ..About your questions , The application asked me to reorganize after deletion About the restoring library i didnt use rstlib , i just had made  a copy of it about 6 monthes ago ... all what i did is replace the existing one with the old one >>> The problem is that the user don't logon to the application any more is there a way to logon into the application from qsecofr to modify the users data Thank you very much once more
    430 pointsBadges:
    report
  • TomLiotta
    all what i did is replace the existing one with the old one   Can you explain how you did that? There are a couple possible ways, but the problems caused can be very different. A library would normally be 'restored' with the RSTLIB command. By "replacing" without using RSTLIB, it's not clear what procedure was done.   I strongly suggest finding someone close who has done some AS/400 programming. A lot of simple things could be possible  with just a little experience. A description of how the "replace" was done might be enough to go forward, but even basic experience would be extremely helpful.   I don't recall knowing anyone near Cairo, but I might be lucky enough to track someone down. If I do, I'll see if I can convince them to contact the Cairo Opera House.   Tom
    125,585 pointsBadges:
    report
  • TomLiotta
    Do you know if the system runs any backup procedures? Are backup tapes generated or other backup formats?   Tom
    125,585 pointsBadges:
    report
  • abar1
    Mr. TOM i really thank you very much for trying to help .. What i did is went to the library and type option 3 (copy) and make a copy of it When the problem happened i replace the existing one with the copy i had done This way succeeded with me in other problems but not that one 
    430 pointsBadges:
    report
  • TomLiotta
    Using a 'copy library' operation to make the copy is helpful to know, but I still don't see how the "replace" was done. Did you use the same 'copy library' option to do the replacing? -- Tom
    125,585 pointsBadges:
    report
  • abar1
    yes i used the same copy operation to replace the library 
    430 pointsBadges:
    report
  • TomLiotta
    Do you know if any backups were ever made of the library? And do you know of any programmer tools on the system such as PDM? You could determine for PDM by typing WRKOBJPDM on a command line, pressing [Enter] and seeing whether a list of objects or an error shows up. -- Tom
    125,585 pointsBadges:
    report
  • abar1
    I did Mr. tom i found no errors The problem that the company that did this system was in canada and it was closed so i dont find any help
    430 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following