JDE with Robot/Schedule

175 pts.
Tags:
iSeries
JDE
Hi All, Our new E1 interface to Robot seems to have created an issue where previous EDI react jobs are not finishing in the OS and so Robot Schedule continues to think they are still running. After looking at the job log for the hung job I noticed it only created a data queue in the ROBOTLIB. I check this by entering WRKOBJ ROBOTLIB/RJ*. There are no more entries in the job log after “Object copied.” I know the job is running properly if a JDE job shows a data area being created. When I do an F1 on one of the “Object copied” messages in the job log it will show an error in the IFS entry. Help Systems says that we are rolling job numbers since we rarely IPL or recycle the Robot products. I’ve started to recycle Robot every other week and the conflicts have diminished, but it still does happen. Has anyone had the same problem, and what did you do to correct it?

Software/Hardware used:
iSeries V6R1
ASKED: March 7, 2013  4:00 PM
UPDATED: November 20, 2013  3:04 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hi All, well I went ahead and updated ALL my Help Systems products.  The person before me hadn’t upgraded the products in a long time.  After the upgrades, I no longer have issues with hanging jobs.  It did however cause one issue that really isn’t one.  They were using multiple RUNUBEs in one robot job and some of those RUNUBEs were terminating.  It did not happen before the upgrade.  I found out from Help Systems you can only have one RUNUBE per robot job.  Once I created a group job it corrected the problem.  Even their documentation said to do it this way so I don’t know why it didn’t fail before.

Discuss This Question: 5  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • CharlieBrowne
    Have you tried to contact HELP System for support of their product? They have great support.
    39,815 pointsBadges:
    report
  • TomLiotta
    If Support at HelpSystems says it's because of job number rollover, tell them they need to fix it. It's a bug in their product. Job number rollover is a system characteristic that's been around since job numbers have first existed. There is no reason it shouldn't be handled by any product that uses job numbers. In fact, job numbers (nor even full 26-character job names) should not be used if uniqueness is required for proper operation; they are known not to be unique. And if uniqueness isn't at the heart of the problem, then rollover shouldn't matter. -- Tom
    125,585 pointsBadges:
    report
  • northwoods
    Hi Charlie, Yes, I have been on the phone with Help Systems a number of times about this issue already. I agree Tom, number roll overs should not have a bearing at all. I am hoping in the future to upgrade the Help Systems products that we have. This has been an issue long before I came to the company and the person before me was already gone before I was hired so I don't know what steps he took research the problem.
    175 pointsBadges:
    report
  • TomLiotta
    I wish I could give something useful, but there's seldom a good way to work around something that's internal to a product (without access to source code). If upgrades are available that handle the problem, or if the problem can be fixed by patching the upgraded version, you might be in a tough spot. H/S Support (like everyone) will be focused on current releases. -- Tom
    125,585 pointsBadges:
    report
  • CharlieBrowne

    Thanks for the update.

    Most people do not let us know what solution if any, worked for them.

    39,815 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following