iSeries Email using SNDDST: problems…

45 pts.
Tags:
AS/400
IBM iSeries
SNDDST
V5R3
Hello you all, Well I'm trying to write a small CL to inform me via email of some messages that I received on my AS/400. I've been browsing IBM site, this site... and other to find how to send email via my AS/400... but it's still not working... I'm running V5R3... and my SMTP mail server runs on a Linux machine: ip 122.1.3.100. What I'm trying to do is to send an email via the command: SNDDST TYPE(*LMSG) TOINTNET(('myemail@mycompany.com')) DSTD('TEST') LONGMSG('TEST EMAIL') When I run this command, I received nothing on our SMTP mail server or in my mail but on the AS/400, I have this:CPC9033 Send distribution completed successfully. Well, I'm sure this is a config problem but where ??? Could you help me debug what's wrong? Thanks in advance... The subsystems are well started: QSNADS QSYS SBS 0,0 DEQW ATLSUPL QSNADS BCH 0,0 EVTW QSYSWRK QSYS SBS 0,0 DEQW QMSF QMSF BCH 0,0 DEQW QMSF QMSF BCH 0,0 DEQW QMSF QMSF BCH 0,0 DEQW QTSMTPBRCL QTCP BCH 0,0 DEQW QTSMTPBRSR QTCP BCH 0,0 DEQW QTSMTPCLTD QTCP BCH 0,0 DEQW QTSMTPSRVD QTCP BCH 0,0 SELW Here is how I configure my AS/400: 1 - Specify the SMTP server: CHGSMTPA AUTOSTART(*YES) MAILROUTER('122.1.3.100') FIREWALL(*YES) ALWRLY(*BOTH) 2 - Accept all ip addresses from my network to use this new SMTP server: ADDSMTPLE TYPE(*ACCEPT) INTNETADR('122.1.3.0') SUBNETMASK('255.255.255.0') 3 - Add a gateway to SNADS: ADDDIRE USRID(MAIL GATEWAY) USRD('SMTP Mail Gw') PREFADR(NETUSRID *IBM ATCONTXT) CHGDSTA SMTPRTE(MAIL GATEWAY) After doing those config, I stopped and restarted the SMTP server: ENDTCPSVR *SMTP STRTCPSVR *SMTP Last thing, during all my tests, I was logged under QSECOFR and I had an SMTP e-mail address for the user QSECOFR via PF19 of WRKDIRE Display Name for SMTP User ID/Address . . . . . : QSECOFR QSECOFR SMTP user ID . . . . . : AS400 SMTP domain . . . . . . : MYCOMPANY.COM SMTP route . . . . . . : But still no email received... How can I debug what's wrong ? Any ideas of the problem ? Thanks in advace for your help.

Answer Wiki

Thanks. We'll let you know when a new response is added.

One small thing, unless its changed in V5R3, you’ll need to also run the STRMSF after the STRTCPSVR

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • PierreLG
    Thanks for the infos... Yes, the QMSF was running... But I'm progressing... QMSF has some errors while trying to reach /QTCPTMM directory and subdirectories... Well, QTCPTMM directory is well present but none of the other subdirectories except MAIL... How can we reinstall those ? Thanks, Best regards,
    45 pointsBadges:
    report
  • PierreLG
    [...] messages that I received on my AS/400. I've been ... Well, qtcptmm directory is well present ...http://itknowledgeexchange.techtarget.com/itanswers/iseries-email-using-snddst-problems/Read "RE: 8 Best E-mail Clients for Linux" at Linux/Unix ForumAre you using them to check your mail [...]
    0 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following