iSeries Access For Web – Run SQL Function

95 pts.
Tags:
iSeries
iSeries Access
iSeries Web-enabling
SQL/400
V5R4
WAS 6.1
Hi Has anyone had the problem where iSeries Access For Web does not run some SQL features consistently? I have a customer that is using this to provide reports from the iSeries to his customers. Customers can log onto the iSeries from the web and get to run reports already created. The customer can run a request that either sends the output to an email with a PDF or XLS as an attachment. Also, other run requests are created, which send the PDF or XLS to the browser screen. However, a request has been created (from the same SQL) that simply displays the output in the browser, but this errors stating that "the policy is restricted". The customer access has been tightened down using the 'customise' option to restrict many policies. The only policies that the user sees are '5250' to start a pre-configured session from a shortcut and 'Database - My Requests' to run shortcut requests already created for them. The 'Run SQL statements' has been denied, but I don't this is the problem cause because the PDF and XLS output formats are displayed (the back end SQL logic is the same throughout). The iSeries is at V5R4M0 (C8057540) with iSeries Access For Web V5R4 (SI31883 PTF); WAS 6.1 Express & IBM 32bit Java installed. Any thoughts? Thanks Richard Mansell. P.S. I have the policies file available if anyone wants to see it.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hi

I think I have solved my problem, or a work around at least.

It would appear that when running an SQL request and sending the output to a browser as a ‘preview’, the process errors with an authorisation issue.
However, if I change the type to browser and ‘HTML’ output, the process runs successfully.

But even HTML output still has its problems. Setting the HTML as the default without any lines per page produces an output. Setting HTML with any number of lines per page, gives the error message about authorisation.

I think there is a bug with iSeries Access for Web at V5R4M0.

Regards
Riccardo

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following