InterVlan on Cisco 3560G series switch and Internet Access

60 pts.
Tags:
Cisco 3560
Cisco switches
InterVLAN
InterVLAN Routing
Routing
VLAN
I have a cisco 3560G and 2911 series router.The Router has 2 internet interface.One is already configured to an unmanaged switch.The second interface is also configure and it can go to the internet.My task is to configure vlans on the switch and the vlans should communicate with each others.Also each of the vlans should have internet access.using the second interface on the router.Can someone help me with step to step how to do it.I'm new to vlan and inter-routing.Thanks.

Software/Hardware used:
cisco switch 3560 and router 2911

Answer Wiki

Thanks. We'll let you know when a new response is added.

Let;s say you have three VLAN’s, VLAN 10, 20, and 30.

On switch, you will need to create VLAN and name them, assign appropriate Interfaces to one of three VLAN’s, create logical VLAN interfaces and assign them an IP Address, and configure ONE interface – the one that connects to router – as trunk.

On router, you will need to configure sub-interfaces.

Below is sample config.

SWITCH
========

config t
vlan 10
name user
exit
vlan 20
name server
exit
vlan 30
name printers
exit

int vlan 10
ip address 10.10.10.1 255.255.255.0

int vlan 20
ip address 10.10.20.1 255.255.255.0

int vlan 30
ip address 10.10.30.1 255.255.255.0

int fast 0/1
switchport access vlan 10

int fast 0/5
switchport access vlan 20

int fast 0/10
switchport access vlan 30

int fa 0/24
switchport encapsulation dot1q
switchport mode trunk

ROUTER (Assuming you have switch port 0/24 connected to router port Gig0/1)
========

int g 0/1.10
encap dot1q 10
ip address 10.10.10.254 255.255.255.0

int gig 0/1.20
encap dot1q 20
ip address 10.10.20.254 255.255.255.0

int gig 0/1.30
encap dot1q 30
ip address 10.10.30.254 255.255.255.0

int g 0/1
no sh

================
The above will get your switch and router to talk. In addition, you will have to configre your router correctly for NAT to all three VLANs can access Internet.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • ralph123
    thanks Pkpatel1151.Your tutorial was very helpful.but can you help me out with NAT on a Vlan.I mean a sample NAT config. so that I can use it for others vlans created.thanks again.Anticipate your reply.
    60 pointsBadges:
    report
  • pkpatel1151
    Sure. So let's assume that your WAN interface is Gig 0/0 on router. You will need three things. 1. Access list
    ip access-list extended NAT-ACL
    
    permit ip 10.10.10.0 0.0.0.255 any
    
    permit ip 10.10.20.0 0.0.0.255 any
    
    permit ip 10.10.30.0 0.0.0.255 any
    
    2. NAT Translation
    
    ip nat inside source list NAT-ACL interface gig 0/0 3. Assign NAT to Interface accordingly.
    interface gig 0/1.10
    
    ip nat inside
    !
    
    int gig 0/1.20
    ip nat inside
    !
    
    int gig 0/1.30
    
    ip nat inside
    !
    
    int gig 0/0
    ip nat outside
    
    And that should do.				
    430 pointsBadges:
    report
  • ralph123
    Thank you very much Pkpatel1151.I will try that now
    60 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following