How to configure Cisco router 2811

10 pts.
Tags:
Cisco 2811
Cisco Routers
Halo We purchased a Cisco router 2811 with two Ethernet ports: Fast Ethernet 0/0 and Fast Ethernet 0/1, but without WAN interface cards! How can I configure one of the ports to work as a WAN port and the other to act as LAN port, so as to enable the 2811 router exchange information with other routers in the Internet and control traffic in our computer network? Send me a copy of a suitable configuration script. NB: Configuration of: line vty Interfaces vlan NAT ACL DHCP DNS I have been configuring Cisco router 800 series only and the 2800 series are new to me. Regards

Software/Hardware used:
Software: IOS version 12.4(13r)T11

Answer Wiki

Thanks. We'll let you know when a new response is added.

The answer really depends on how your Internet connection is provided.

If your Internet connection is presented to you as Ethernet, like you get from cable operators, then you have the correct router hardware. However, I would have recommended that you bought a Cisco ASA firewall rather than the router to do this task as it provides a much higher secure firewall capability.

If your Internet connection is presented as ADSL, or some other WAN connection, then you will need to purchase the correct WAN interface, and install this in the router. The ethernet interfaces can not be reconfigured to be WAN interfaces, that is not possible.
The alternative would be to buy a separate modem to do this, and configure that to interface between the internet connection and your Cisco router.

If you are already familiar with the 800 series, then you already know how to configure the 2811. The beauty of Cisco routers, is that they all use the same basic command syntax for the operating system. The main change you need to make is probably to the name of the interfaces, the 800 configuration is a good starting point, but change the interface names to the fastethernet0/0 and fastethernet0/1 of the 2811. If you don’t have the 800 configuration, then there is a very basic one shown below. I would recommend you add some further access lists to restrict traffic from the Internet, but the firewall software will do most of this for you. Ask if you need this information.

I would highly recommend that you also purchase, and install the firewall version of the operating system, as this will further protect your internal network.

service password-encryption
!
hostname Router
!
! configure a secure enable password
enable secret cisco
!
!— The LAN interface
interface FastEthernet0/0
 description LAN
 ip address <address on LAN> <subnet mask>
 ip nat inside
 duplex auto
 speed auto
!
!— This is the LAN interface connected to your Internet.
interface FastEthernet0/1
 description Internet
!— if you have a fixed IP address from your ISP
 ip address <address given to you by the ISP> <subnet mask>
!— or if it is not fixed
 ip address dhcp
!
ip nat outside
 ip virtual-reassembly
duplex auto
 speed auto
 no shutdown
!
!— Configure address translation to allow LAN access to Internet
ip nat inside source list 101 interface Ethernet0/0 overload
!
!— Access list 101 permits LAN network to be NATed – note subnet mask

!— is reversed choose the correct value to mirror your LAN subnet mask
access-list 101 permit <LAN_Subnet> 0.0.0.255 any
!
!— The default route
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
line con 0
line aux 0
line vty 0 4
 password cisco
 transport input all
line vty 5 15
 password cisco
 transport input all
!
end

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following