How can I configure a connection by pppoe on a Cisco 2600 Router?

5 pts.
Tags:
Cisco 2600
Cisco Routers
CPE
Microsoft Windows 7
PPPoE dialer
PuTTY
Wireless
please can somebody help me to find out the way i can configure a connection by pppoe on a Cisco 2600 Router?

Software/Hardware used:
win7, putty, cisco 2600 router

Answer Wiki

Thanks. We'll let you know when a new response is added.

Here is a sample config for PPPoE configuration. Replace interface names, usernames and passwords with the right ones for you network. Authentication details should come from your ISP.

vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
interface FastEthernet0/0
description My LAN
ip address 10.0.0.0 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
description Connection To PPPoE Supplier
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap
ppp pap sent-username “username” password “password”
!
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 1 permit 10.0.0.0 0.0.0.255

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • T8sta
    [...] T8sta wondered, “How can I configure a connection by PPPoE on a Cisco 2600 router?” And Mattmather came to the rescue with a sample for PPPoE [...]
    0 pointsBadges:
    report
  • T8sta
    [...] T8sta needed help configuring a connection by PPPoE on a Cisco 2600 router. Mattmather provided a thorough answer; have anything to [...]
    0 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following