configuring L3 switch to router

400 pts.
Tags:
Cisco
Cisco Internetworking
L3 Switches
Routers
I have router having public address in F0/1 and S0/0

I have no firewall, Hence i am connecting Cisco 3560 Switch directly to the router. but i am anable to ping from my local vlans to the S0/0

I tried Nat and all the thing by switch port and no switch port commands. Every thing i tried.

I i come to think that There is a special configuration for such scenarios. Can anybody know this?

Please send the detail info with configuration.  

 



Software/Hardware used:
Cisco Router 1841 and Cisco L3 switch 3560
ASKED: December 29, 2009  11:16 AM
UPDATED: October 14, 2011  4:59 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hello,

It sounds like the default gateway may not be set correctly on the 3560. There are a couple other possible causes, but this is the most likely.

Hope this helps…

Ryan

————————————————————————–

I disagree w/ Ryan – it sounds more like a misconfigured trunk link between the Switch and your router…
As I mentioned in your other post about the same topic, try the following config to get your VLANs / Trunking working:

Cisco 3560:
Set up VLAN interfaces to be “trunk-ready”

3560(config)#interface VLAN 1
3560(config-if)#ip address 192.168.1.2 255.255.255.0
3560(config-if)#no shut
3560(config-if)#exit
3560(config)#Int VLAN 2
3560(config-if)#ip address 192.168.2.2 255.255.255.0
3560(config-if)#no shut
3560(config-if)#exit

Now set up your trunk:
3560(config)#int fa0/4
3560(config-if)#switchport trunk encapsulation dot1q
3560(config-if)#switchport mode trunk
3560(config-if)#switchport trunk native vlan 1
3560(config-if)#switchport trunk allowed vlan add 2 (or “sw trunk allowed vlans all”)
3560(config-if)#end
(save config if you wish)

Cisco 1841:
Now set up the trunk port on the router:

1841(config)#int fa0/0
1841(config-if)#no ip address
1841(config-if)#no shutdown
1841(config-subif)#int fa0/0.1
1841(config-subif)#encapsulation dot1Q 1
1841(config-subif)#ip address 192.168.1.1 255.255.255.0
1841(config-subif)#int fa0/0.2
1841(config-subif)#encapsulation dot1Q 2
1841(config-subif)#ip address 192.168.2.1 255.255.255.0
1841(config-subif)#exit

if its done right, you should see something similar to this:

%LINK-5-CHANGED: Interface FastEthernet0/4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Configure the 1841 to get to you ISP as needed, and all users should be able to get online easily from here. Test pings from the devices used to assist in this config show the following results:

3560#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 31/31/31 ms

3560#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 31/31/32 ms

Let us know how it goes…

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • 0779360742
    plz help me i want connect 190 pc's by vlan. how to use of segment/
    10 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following