Cisco router 2821 configuration NAT and DHCP

15 pts.
Tags:
Cisco
Cisco 2821
Cisco router configuration
DHCP
Router configuration
I trying to make it works but still to no avail. Maybe somebody can help me with my problem. I configure my router 2821 with 2 Gic interface and 16 ports fastethernet.
Here's what I need to accomplish:
Int Gi 0/0 WAN-outside
Int Gig0/1 LAN-inside
VLAN 5 DHCP  (another network)
Note: LAN users can able to access the internet but the VLAN 5 network could not work.
here's my configuration 
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cmi-core_de
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$nhhd$HrKYhyzWT9XU/tLE5/GZM/
!
no network-clock-participate aim 0 
no network-clock-participate aim 1 
no aaa new-model
ip subnet-zero
!
!
ip cef
ip dhcp excluded-address 192.168.5.1
!
ip dhcp pool LAN_ARRAK
   network 192.168.5.0 255.255.255.0
   default-router 192.168.5.1 
   dns-server 192.168.0.3 4.2.2.1 
   domain-name noname.com
!
!
no ip domain lookup
ip domain name noname.com
ip name-server 4.2.2.1
no ftp-server write-enable
!
!
!
!
interface GigabitEthernet0/0
 ip address 118.103.91.229 255.255.255.0
 ip nbar protocol-discovery
 ip pim dense-mode
 ip nat outside
 duplex auto
 speed auto
 no cdp enable
!
interface GigabitEthernet0/0.5
 encapsulation dot1Q 5
!
interface GigabitEthernet0/1
 ip address 192.168.0.245 255.255.255.0
 ip nbar protocol-discovery
 ip nat inside
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet1/0
 switchport access vlan 5
 no ip address
!
interface FastEthernet1/1
 switchport access vlan 5
 no ip address
 shutdown
!
interface FastEthernet1/2
 switchport access vlan 5
 no ip address
 shutdown
!
interface FastEthernet1/3
 switchport access vlan 5
 no ip address
 shutdown
!
interface FastEthernet1/4
 switchport access vlan 5
 no ip address
 shutdown
!
interface FastEthernet1/5
 switchport access vlan 5
 no ip address
 shutdown
!
interface FastEthernet1/6
 no ip address
 shutdown
!
interface FastEthernet1/7
 no ip address
 shutdown
!
interface FastEthernet1/8
 no ip address
 shutdown
!
interface FastEthernet1/9
 no ip address
 shutdown
!
interface FastEthernet1/10
 no ip address
 shutdown
!
interface FastEthernet1/11
 no ip address
 shutdown
!
interface FastEthernet1/12
 no ip address
 shutdown
!
interface FastEthernet1/13
 no ip address
 shutdown
!
interface FastEthernet1/14
 no ip address
 shutdown
!
interface FastEthernet1/15
 no ip address
 shutdown
!
interface Vlan1
 no ip address
!
interface Vlan5
 ip address 192.168.5.1 255.255.255.0
 ip nat inside
!
ip classless
ip route 0.0.0.0 0.0.0.0 118.103.91.69
ip http server
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 password 7 121A081E44525E
 login
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 094F43004F5C45
 login
!
scheduler allocate 20000 1000
!
end


Software/Hardware used:
cisco 2821

Answer Wiki

Thanks. We'll let you know when a new response is added.

Hello there!

It is my understanding that the 2821 integrated service router cannot do VLAN’s on the GE ports.

So if this is correct, “by design” you approach to this problem is not most correct.
You can’t use GE ports to do VLAN’s (in this router).

My sugestion is that you don’t use those ports and change the configuration according to the new ones that will use.
Besides, only if you have a very larga pipe to your provider, you probably don’t need GE ports to the Internet traffic…

With best regards,

Luís

————————————

Why do you have a subinterface Gi0/0.5? with the switchports set to access in VLAN 5 an directly cabling devices into the router, the subinterface is unnecessary.

Also, I dont see your VLAN1 IP address anywhere. Cisco devices, by default, operate on VLAN 1 natively. Since you’re treating this like a multi-layer switch, turn up VLAN1 with a management IP address, and, if you want VLAN 5 to be your “native”, set the PVID of the router to VLAN 5…

Discuss This Question: 4  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Bonsan
    Thank you for your reply. My apology, I didn't mentioned that it has 16 fastethernet ports which I used for DHCP VLAN 5
    15 pointsBadges:
    report
  • Seydcoul
    Here's an exemple of DHCP configuration on 2821 ip dhcp pool internalnet network 192.168.0.0 255.255.255.0 default-router 192.168.0.3 domain-name hoge.local netbios-name-server 192.168.0.1 192.168.0.2 netbios-node-type h-node dns-server 202.1.1.1 202.1.1.2 lease 5
    10 pointsBadges:
    report
  • Netfile
    Try to use switchport mode access and switchport access vlan 5 on your fasatethernet ports.
    25 pointsBadges:
    report
  • Netfile
    Also apply no shutdown on fastethernet ports
    25 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following