Cisco 2811 configuration for managing traffic through two Internet connections

5 pts.
Tags:
Cisco 2811
Cisco 2811 configuration
Network traffic management
How can I use a Cisco 2811 configuration for managing traffic through two Internet connections?
ASKED: March 3, 2009  9:08 PM
UPDATED: June 10, 2013  6:11 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

I am running a similar setup here is my config and notes:

Current configuration : 2187 bytes <Delete this, :this is the file size, will produce an error message if in a sript
!
version 12.4 <Delete this: This is the ios verion
service timestamps debug datetime msec <This puts a date on messages that are collected with the debug command, debug is for troubleshooting
service timestamps log datetime msec <This puts a date on messages that are collected by a syslog server taht is set up to collect notifications, eror messages, etc
no service password-encryption <This turns off!! encrypting the passwords on your machine which looks like they are mostly missing.
! <You have an enable password, enable secret, line con 0 password, line vty password in a basic setup
! <You do have user names with passwords that are encrypted with MD5 down the config
!
hostname LOANOFFICE-2811 <sets the prompt with the command hostname NewRouterNameNoSpacesAllowed, can be used with ppp authentication
!
boot-start-marker < ***new to me not a command, a sort of start point with no boot direction commands included, commands would stop at

boot-end-marker
boot-end-marker < see above
!
card type t1 0 0 <i believe that’s how you set the card to be in T1 or E1 mode. The command is card type t1 or e1 0 0
!
no aaa new-model <To enable the AAA access control model, use the aaa new-model global configuration command. Use the no form of this command to

disable.
!
! resource policy <you can define Embedded Resource Manager (ERM) policy that raises an alert when the CPU utilization of the IP Input process exceeds

predefined limits.
!
!
no network-clock-participate wic 0 <T1 timing, I believe this makes the time get pulled from the line and not wic0, but I am not sure
ip subnet-zero <This allows use of the first subnet in you ip address plan, which in the old days (80′s, etc) could not be used, first and last address rule.
!
!
! ip cef <Express Forwarding (CEF) advanced, Layer 3 switching technology inside a router. Changes how Cisco router forwards packets from
! < ingress to egress interfaces. Used instead of process switching. CEF relieve load on the CPU

no ip dhcp use vrf connected <not sure of this one, may have something related to MPLS networks which use VRF templates
ip dhcp excluded-address 172.16.3.1 172.16.3.49 <address .1 to to 49 are not given out, reserved for staic assignment, printers, servers, router interfaces, etc.
!
ip dhcp pool Phones <creates a set of address under the name “Phones” so can be used for dhcp on your phones, “Phones” can be referenced like a

variable later
network 172.16.3.0 255.255.255.0 <looks like a whole subnet being used for phones 172.16.3.50 to 172.16.3.254 (remember excluded cmd above) scope on a

server
option 150 ip 172.16.1.20 172.16.1.22 <not sure, but, Option 66 only allows 1 host, option 150 more than 1 ip address, which can be used for TFTP redundancy.
default-router 172.16.3.1 <Default gateway setting for dhcp assignment to PC’s , ip phones, etc most likely phones
dns-server 10.8.1.10 10.8.1.11 < sets 2 domain name servers so that address resolution can occur, these can be given out with dhcp assigment.
!
!
ip multicast-routing <turns on use of multicasting, referencing with ip to mutiple computers
<without the need for unicast connection, but saves bandwidth because not a broadcast
!
voice-card 0 <access the card for command that follows
no dspfarm <I do not know this cmd, something is being disabled
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1 <do not know yet
rule 1 /^2041/ /141/ <do not know yet
!
!
!
!
username ans privilege 15 secret 5 $1$QuGR$4SsJ08xxWJgP90pgj8Q55. <creates a user name “ans” and encrypted password, with 5=MD5 encryption
username administrator privilege 15 secret 5 $1$m9O5$izWmzxEO3TjU/MKNxo6ov1 <like above, the secret seems to set the enable secret or privledged password
! <level 15 is Cisco administrator / super-user access
!
controller T1 0/0/0 <Settings for the interface T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
description point to point circuit # 80.dhzx.552978
!
controller T1 0/0/1 <Settings for the interface T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
description T1 to FiData
!
!
!
interface FastEthernet0/0 <settings for fa0/0
description Link to Data VLAN 1 <just a comment or remark
ip address 10.8.3.1 255.255.255.0 < set ip and subnet mask
ip helper-address 10.8.1.10 <a broadcast assistance command to help find a server
ip pim sparse-dense-mode <do not know
duplex auto <can be half(old hub like behavior), full (talk in both directions at same time) or auto
speed auto <can be 10 Mbps or 100, or auto of course
< *******Important all interfaces need a “no shut” command or will not come up, NOT SHOWN IN CONFIG!!!
!
interface FastEthernet0/1 <same as above, no seting because below on subinterface (routing between vlans config)
description Link to Voice VLAN 10
no ip address
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1.10 <this is a sub interface for a trunk line to a switch, connects to vlan 10 to route between vlan 1 and 10
description Link to Voice VLAN 10 <comment line
encapsulation dot1Q 10 <can be ISL o some routers or dot1Q (standard you should use), the 10 means vlan 10
ip address 172.16.3.1 255.255.255.0 <set ip
no snmp trap link-status <related to recording simple network management info
!
interface Serial0/0/0:0 <see above related descriptions
description Virtual interface for T1 to Operations
ip address 10.254.254.62 255.255.255.252
ip pim sparse-dense-mode <Do not know
!
interface Serial0/0/1:0
description Unused
no ip address
encapsulation ppp
!
router ospf 108 <Dynamic routing protocol being started, Open shortest path first with process id 108
log-adjacency-changes <track neighbor routers changes
redistribute connected subnets <used to force dynamic protocol to send info about attached networks to ajacent routers and/or main ospf router
network 0.0.0.0 255.255.255.255 area 0 <Include all interfaces in OSPF routing table 0.0.0.0 255.255.255.255 means “all”, area 0 is backbone area.
!
ip classless <allows subnetting to work properly by making routing classless, so router will not drop packets but instead foward if defauft route exists
ip route 10.1.1.0 255.255.255.0 10.254.254.61 <a static route, to get to 10.1.1.0 go out your interface toward or connected to 10.254.254.61
ip route 172.30.8.0 255.255.255.0 10.254.254.61 <same as above with different numbers
!
!
no ip http server <turns off access to web-interface on http (port 80), a way to protect from hacker access
no ip http secure-server <turns off access to web-interface on https
!
!
!
!
control-plane <do not know, looks line a a module control area
!
!
!
voice-port 0/1/0 <do not know, a VoIP port connection control area
!
voice-port 0/1/1
!
!
!
!
!
!
!
line con 0 <place to put console port security, ie password
line aux 0 <as above but a modem port
line vty 0 4 <as above but for commands related to telnet 0 4 means 0,1,2,3,4 or 5 lines
login local <control telnet behavior, login turns on authentication, will use user name database set above
!
scheduler allocate 20000 1000 <do not know
!
end <ends config script.

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following