Cisco 2811 Fast Ethernet and LAN configuration

5 pts.
Tags:
Cisco
Cisco 2811
Cisco router configuration
Cisco Routers
Fast Ethernet
LAN configuration
Router configuration
Routers
i have cisco2811 router and i want to configure its 2 fast ethernet on my isp and PC or lan. can someone with a good heart to help me what command i will use on configuration level on both router and lan to have an internet connection.

Answer Wiki

Thanks. We'll let you know when a new response is added.

To start with, I need to make some assumptions, as the information you have given is not very much. The ISP will provide an ethernet connection for you, and your PC will use DHCP to get it’s own IP address.

Based on that, you should be able to use the following.

First erase any existing configuration on the router. At the # prompt type

wr erase

Accept any questions by hitting the return key. Then power off the router for ten seconds, and turn it back on again. When it asks if you want to do the initial config, answer no.

Type the following

en
conf t
enable secret {password for enable mode}
no ip domain-lookup
ip classless
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 208.67.222.222 208.67.220.220 (or replace with the DNS servers supplied by the ISP)
!
interface fastethernet0/0
description ** LAN **
ip address 192.168.0.1 255.255.255.0
ip nat inside
no shutdown
!
interface fastethernet0/1
description ** Internet **
ip address dhcp
ip nat outside
no shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
line vty 0 4
access-class 1 in
password {telnet password}
login
!
end
wr

That should get the basics going. If you have a fixed IP address from the ISP, put that in the FastEthernet0/1 config, instead of the dhcp part of the command, and also change the ip route to be the ISP router, instead of the FastEthernet0/1.

You may not need the “ip route 0.0.0.0 0.0.0.0 FastEthernet0/1″ command at all, as the default route should be inserted by dhcp from the ISP. If on a newer version of IOS (mostly I still work with 12.2) there is an “ip route 0.0.0.0 0.0.0 dhcp” command that you could also use to replace this. Try each one, and do a ‘show ip route’ command to see if the default route has been put in the table. When it has, stop !

Provide some feedback here if you are having problems, or need more information. A copy of the configuration (show config command at the enable prompt # ) will help a lot.

I apologise if I have left anything out, (I am sure someone will point this out !), but I did this from memory.

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • NWEA
    Consider you have link which is terminate in ethernet port of router and use internet in your LAN. ISP provide you LAN and WAN ip pool. So to configure steps on your router - configure line console, aux, vty, enable, enable secret password. configure interface fa0/0- router#conf t router<conf>#int fa0/0 router<config int># ip address <ip address> router<config int># description WAN router<config int># ip nat outside router<config int># no shut configure interface fa0/1 router#conf t router<conf>#int fa0/1 router<config int># ip address <ip address> router<config int># description LAN router<config int># ip nat inside router<config int># no shut configure default route - router<conf>#ip route 0.0.0.0 0.0.0.0 <ip address of ISP/Next hop ip add> configure ACL and PAT - router<conf>#access-list 1 permit any router<conf>#ip nat inside source list 1 interface fa0/0 overload Save configuration in startup-config file - router#copy running-config startup-config then check configuraiton by - router#sh run router#sh start check port status - router#sh ip int brief check ping to each port and ISP ip address.
    55 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following