RPGLE: Change default debug view

2820 pts.
Tags:
RPGLE
Source code
Hi
I am using V5R1. Every time when I have to compile a code in debug mode I have to change debugging view to source. I want it to set as default and whenever I compile the code it should compile it in debugging view = source.
Thanks in advance.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Use the CHGCMDDFT command.
CHGCMDDFT CMD(CRTBNDRPG) NEWDFT(‘dbgview(*source)’)     

Discuss This Question: 6  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Splat
    We have a 'system' library specific to our installation that is set to the first library of the system portion of the library list.  When modifying a command we first duplicate it to that library then modify the duplicate.  We find it limits potential problems & makes it easy to reverse any changes if they're causing problems..
    10,075 pointsBadges:
    report
  • CharlieBrowne
    We have a source member where we store any commands we use to modify IBM objects when we chose to modify rather than duplicate.
    This has a couple of nice advantages:
    1. Look in one place to see what objects have been modified.
    2. Be able to see the specific changes made to the objects.
    3. Load a new release and just call this program to make the changes required for our company.
    62,280 pointsBadges:
    report
  • hunshabbir7
    Thnx Charlie for always helping.
    I have used command you mentioned and it was successfully executed, but when I again try compiling program; debugging view value was as previous and I have to change it again manually.
    2,820 pointsBadges:
    report
  • CharlieBrowne
    Are you using the CRTBNDRPG command to create your program or either CRTRPGMOD or CRTRPGPGM.
    I'll guess it is one of those. If so, change the default for those commands.
    62,280 pointsBadges:
    report
  • hunshabbir7
    Thnx Charlie finally it worked. Actually we had some electricity issue and our server abnormally shut down. When it came back, its default debugging view was just OK. I guess this command needs restart. 
    2,820 pointsBadges:
    report
  • CharlieBrowne
    I'm glad I could help.
    Thanks for coming back and letting us know that we could assist you.
    Most people do not do that.
    62,280 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: