Catalyst 3550 VLAN ADSL

5 pts.
Tags:
ADSL Modem
Networking
VLAN
I need to configure 6 VLANs in my Cisco Catalyst 3550 switch with 6 VLANs and 1 connection to the internet trough an ADSL modem, but I need the 6 VLANs to get access to the Internet using the same modem.

Software/Hardware used:
catalyst 3550
ASKED: February 20, 2013  3:04 PM
UPDATED: February 20, 2013  4:06 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

Here is a sample config. Remember vlan 1 is default vlan for all interface , until you switch the interface to other vlan.

!<create gateway for each vlan>
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 descr lan 1
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 descr lan 2
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
 descr lan 3
!
interface Vlan4
 ip address 192.168.4.1 255.255.255.0
 descr lan 4
!
interface Vlan5
 ip address 192.168.5.1 255.255.255.0
 descr lan 5
!
interface Vlan6
 ip address 192.168.6.1 255.255.255.0
 descr lan 6
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
 descr uplink to internet

!<create vlan on switch>
vlan 2
!
vlan 3
!
vlan 4
!
vlan 5
!
vlan 6
!
vlan 10
name uplink

!<put interface in vlan>
int range fa0/7 – 12
switchport mode access
switchport access vlan 2
!
int range fa0/13 – 16
switchport mode access
switchport access vlan 3
!
int range fa0/17 – 18,  fa0/21
switchport mode access
switchport access vlan 4
!
!<and so one>

!
!<ip routing>
ip routing
ip route 0.0.0.0 0.0.0.0 (gateway ip address modem)

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • BlankReg
    You will also need to configure the ADSL router to address translate (NAT) all the subnets used for the different VLANs, and add routes for 192.168.0.0 255.255.0.0 to point to the IP address on the 3550 in the same subnet as the LAN IP of the ADSL router.
    12,325 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following