AS400 RUNSQLSTM – Problem with CAST

41430 pts.
Tags:
AS/400
DB2/400
RUNSQLSTM
SQL Server
V4R5
I am using a RUNSQLSTM to insert records from file A into file B.

One of the fiels in defined as 4S 0 in file A and as 4A in file B.

If the value in file A is zero, not matter what I have tried file B gets populated with a 0 followed by 3 blanks. I need to be '0000'



Software/Hardware used:
AS400 V4R5

Answer Wiki

Thanks. We'll let you know when a new response is added.

I figured out what I needed.
I just used the keyword DIGITS and it resolved my problem.

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following