AS/400 addtional routing entry issue

365 pts.
Tags:
AS/400
AS/400 networking
In My network we have iSeries server with existing routing entry with *DFTROUTE with nexthope  10.3.1.*. We are using this for the intrasite support and planning to host the server in internet using separate IP address, gateway and subnetmask. Through Configure TCP/IP we have added new IP address and submetmask and status shows Active but when we tried to add entry in TCP/IP Routes we are getting an error "  TCP/IP route not added ". I have ended the TCP and tried to add the new route entry but still I'm getting the error. Please assist.

Software/Hardware used:
as/400 , OS version : V7R1

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Discuss This Question: 5  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • TomLiotta

    ...when we tried to add entry in TCP/IP Routes we are getting an error "  TCP/IP route not added ".

    At the very least, we need to see what you tried to add. We can't guess anything without that piece of data. Once we see the route parameters that you tried, we might know what other questions to ask to track down the problem.

    Tom

    125,585 pointsBadges:
    report
  • naresh1984

    Tom,

    Please find the entrys iam adding in my network

                                Display TCP/IP Interface                           
                                                                 System:   AS40001  
     Internet address . . . . . . . . . . . . . . . :   152.16.141.290             
     Subnet mask  . . . . . . . . . . . . . . . . . :   255.255.250.0              
     Line description . . . . . . . . . . . . . . . :   ETHLINE2                   
     Alias name . . . . . . . . . . . . . . . . . . :   *NONE                      
     Alias name CCSID . . . . . . . . . . . . . . . :   0                          
     Line type  . . . . . . . . . . . . . . . . . . :   *ELAN                      
     Associated local interface . . . . . . . . . . :   *NONE                      
     Interface status . . . . . . . . . . . . . . . :   Active                     
     Type of service  . . . . . . . . . . . . . . . :   *NORMAL                    
     Maximum transmission unit  . . . . . . . . . . :   *LIND                      
     Automatic start  . . . . . . . . . . . . . . . :   *YES                       
     Text description . . . . . . . . . . . . . . . :   *BLANK         


    Exisiting One for other TCP/IP
                                  Display TCP/IP Route                         
                                                                 System:   AS40001   
     Route destination  . . . . . . . . . . :   *DFTROUTE                      
     Subnet mask  . . . . . . . . . . . . . :   *NONE                          
     Type of service  . . . . . . . . . . . :   *NORMAL                        
     Next hop . . . . . . . . . . . . . . . :   172.16.111.1                   
     Preferred binding interface  . . . . . :   *NONE                          
     Maximum transmission unit  . . . . . . :   *IFC                           
     Duplicate route priority . . . . . . . :   5                              
     Route metric . . . . . . . . . . . . . :   1                              
     Route redistribution . . . . . . . . . :   *NO                            
     Text description . . . . . . . . . . . :   *BLANK                       

    Adding the New one for TCP/P

                                Add TCP/IP Route (ADDTCPRTE)                         
                                                                                   
     Type choices, press Enter.                                                    
                                                                                   
     Route destination  . . . . . . . > '152.16.141.290'                           
                                                                                   
     Subnet mask  . . . . . . . . . . > '255.255.250.0'                            
     Type of service  . . . . . . . .   *NORMAL       *MINDELAY, *MAXTHRPUT...     
     Next hop . . . . . . . . . . . . > '152.16.140.1'                             
                                                                                   
     Address prefix length  . . . . .   64            1-128, *HOST, *NONE          
     Preferred binding interface  . .   *NONE                                      
     Binding line description . . . .                 Name                         
     Maximum transmission unit  . . .   *IFC          576-16388, *IFC              
     Route metric . . . . . . . . . .   1             1-16                         
     Route redistribution . . . . . .   *NO           *NO, *YES                    
     Duplicate route priority . . . .   *MEDIUM       1-10, *MEDIUM, *HIGH, *LOW   
     Text 'description' . . . . . . .   *BLANK                                     
                                                                                   
    While adding the new Routing entry, iam getting this error "TCP/IP route not added " .This new entry for hosting the server in internet .Hence both having different gateway
                                    

    365 pointsBadges:
    report
  • TomLiotta
    I can't be sure what you're trying to do with a subnet mask value of 255.255.250.0. Either 255.255.248.0 or 255.255.252.0 would make more sense. But using 250 in the third octet makes the intent unclear. It doesn't provide a clear mask. I don't know if that would give the error you're seeing, but it would help to know what you're trying to do. (I see the same odd mask in the interface.) -- Tom
    125,585 pointsBadges:
    report
  • naresh1984

    Hi Tom,

    Yes . the Subnet Mask : 255.255.252.0. I have verfied with network team . But still iam having the same problem . Not able to add addtional routing entry .

    365 pointsBadges:
    report
  • TomLiotta

    I just took another look at your earlier comments. You showed an interface address of 152.16.141.290, and you were trying to add a route to 152.16.141.290.

    Since those are the same addresses, why would to add a route from your AS/400 to your AS/400? That makes no sense. (I should have seen that immediately.)

    Also, have you corrected the subnet mask on the interface?

    Tom

    125,585 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following